View Issue Details

IDProjectCategoryView StatusLast Update
14964Bug reports[All Projects] Otherpublic2019-07-04 17:24
ReporterExtractAssigned ToDenisChenu 
PrioritynoneSeveritymajor 
Status resolvedResolutionfixed 
Product Version3.17.x 
Target VersionFixed in Version3.17.x 
Summary14964: Thème par défaut qui se réinitialise lors de la sauvegarde des paramètres généraux de LS
Description

Lorsque nous choisissons un thème personnalisé comme thème par défaut dans les paramètres généraux de LS et que nous retournons dans les paramètres après un certain temps, le thème par défaut se retrouve sélectionné alors que la valeur dans la base de données (table: lime_settings_global, variable: defaulttemplate) est bien celle du thème personnalisé. Lorsque nous sauvegardons à nouveau les paramètres, la valeur de la bd est remplacé par le thème par défaut.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.17.4
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Versionmysql
Server OS (if known)
Webserver software & version (if known)
PHP Version7.0.32

Activities

Extract

Extract

2019-06-05 22:26

reporter   ~52306

La variable problématique semble en fait defaulttheme qui se réinitialise tout seul...

Extract

Extract

2019-06-06 04:18

reporter   ~52307

En fait, le thème semble se réinitialiser après un certain temps sans que nous retournions dans la section des paramètres généraux.

dominikvitt

dominikvitt

2019-06-12 11:48

developer   ~52358

@Extract:
Can you explain exact steps you used to reproduce this issue?

Extract

Extract

2019-06-12 15:54

reporter   ~52370

We noticed that the default theme reset occurs when running the cron task associated with the "SendMailCron" plugin. But we did not find the cause...

DenisChenu

DenisChenu

2019-07-02 19:18

developer   ~52687

I think it's a LimeSurvey issue related to plugins command action.

See included Plugins

Calling inside LimeSurvey directory : it's OK

$ php application/commands/console.php plugin --target=checkThemeUpdateBug
skelvanilla
skelvanilla

Calling outside LimeSurvey directory : it's OK


$ php www/limesurveyapplication/commands/console.php plugin --target=checkThemeUpdateBug
skelvanilla
vanilla


checkThemeUpdateBug.php (870 bytes)
DenisChenu

DenisChenu

2019-07-04 17:24

developer   ~52738

https://github.com/LimeSurvey/LimeSurvey/commit/387fe4d16f87675dd860cd46e1b74e856eef778d

For previous LimeSurvey version : https://gitlab.com/SondagesPro/mailing/sendMailCron/commit/31165bf12201e3dc82b927df095a8f5221bb73d3

Issue History

Date Modified Username Field Change
2019-06-05 18:52 Extract New Issue
2019-06-05 22:26 Extract Note Added: 52306
2019-06-06 04:18 Extract Note Added: 52307
2019-06-12 11:48 dominikvitt Assigned To => dominikvitt
2019-06-12 11:48 dominikvitt Status new => resolved
2019-06-12 11:48 dominikvitt Resolution open => unable to reproduce
2019-06-12 11:48 dominikvitt Note Added: 52358
2019-06-12 15:54 Extract Note Added: 52370
2019-07-02 19:18 DenisChenu File Added: checkThemeUpdateBug.php
2019-07-02 19:18 DenisChenu Note Added: 52687
2019-07-02 19:18 DenisChenu Assigned To dominikvitt => DenisChenu
2019-07-02 19:22 DenisChenu Status resolved => feedback
2019-07-02 19:22 DenisChenu Resolution unable to reproduce => reopened
2019-07-04 16:58 DenisChenu Status feedback => new
2019-07-04 16:58 DenisChenu Status new => confirmed
2019-07-04 17:24 DenisChenu Status confirmed => resolved
2019-07-04 17:24 DenisChenu Resolution reopened => fixed
2019-07-04 17:24 DenisChenu Fixed in Version => 3.17.x
2019-07-04 17:24 DenisChenu Note Added: 52738