View Issue Details

IDProjectCategoryView StatusLast Update
14910Bug reports[All Projects] Survey designpublic2019-05-24 00:23
Reporterninanu Assigned Toc_schmitz  
PrioritynoneSeveritytweak 
Status feedbackResolutionreopened 
Product Version3.16.x 
Target VersionFixed in Version 
Summary14910: left and right alignment depending on the type of questions
Description

I have a problem concerning the left and right alignment of text depending on the type of questions. As you can see in the attached picture if it's a multiple numerical input the text alignment is right and with "normal" text questions the alignment is left. Is there any way to change the alignment so it's coherent? I would prefer a left alignment for every single type of question.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.16.0+190225
I will donate to the project if issue is resolvedNo
BrowserFirefox
Database & DB-Versiondon't know
Server OS (if known)
Webserver software & version (if known)
PHP VersionPHP

Activities

dominikvitt

dominikvitt

2019-05-20 18:12

developer   ~51996

@ninanu: please attach picture

ninanu

ninanu

2019-05-22 10:00

reporter  

Unbenannt1.png (45,582 bytes)
Unbenannt1.png (45,582 bytes)
Unbenannt.png (62,690 bytes)
Unbenannt.png (62,690 bytes)
jelo

jelo

2019-05-22 10:44

partner   ~52026

Was more a design decision (Think about a spreadsheet like Excel). For L2R languages you have text left-aligned and numbers right-aligned.
That is the case for 3.17.3 too. The questiontypes with numbers are right aligned, the text are left aligned.

For a survey layout a question option to have a different alignment can be quite useful.

DenisChenu

DenisChenu

2019-05-22 10:46

developer   ~52027

Easy fix in themes.css

ninanu

ninanu

2019-05-22 11:09

reporter   ~52030

ok so there is no way for me to fix it considering I don't know what themes.css is and how to use it?

jelo

jelo

2019-05-22 11:21

partner   ~52031

When LimeSurvey GmbH is seeing WYSIWYG as an important feature, the alignment will be not left to CSS modifications.

Easy is relative.

If you know the Themes-Editor (in German Designvorlagen), you can add a part in custom.CSS to change the behavior.

Add e.g.:
.numeric-item input[data-number='1'] {
text-align: left;
}

DenisChenu

DenisChenu

2019-05-22 12:13

developer   ~52035

I don't care about it must be easy or not (css still easy). But right : looking at default behaviour of input type='number' against input type='text' aligment is same in brower default.
number VS text

Then : keep it same ( text-align: start;) is the best solution.

And about GUI feature : all question have more settings than really needed make LimeSurvey very complex to learn … adding again and again a new settings it's not the good solution …

ninanu

ninanu

2019-05-22 12:18

reporter   ~52036

i thank you all for your input. I just think Denis that you cannot go around and tell people what is easy and what is not. This is not meant in any insulting way, but I just want to give you a different perspective. If somebody such as me has never used any kind of css it is going to be hard especially because I am a little scared of messing the whole template up. So please choose your words carefully because at the end we all come from different backgrounds and just because something is easy for you, it might be hard for someone else. Nevertheless I'll try to fix the problem using CSS so thank you for that solution proposal

DenisChenu

DenisChenu

2019-05-22 13:22

developer   ~52043

Sorry for using «easy», you right : it's easy when you know css (a little).

I din't put the css line to add : my error :).

For a GUI settings : clearly i'm unsure we need a GUI settings for this before other settings … else we come with 1 000 000 settings by survey + 1 000 000 question settings finally … and it's worst.

c_schmitz

c_schmitz

2019-05-22 13:44

administrator   ~52044

I am closing this issue because this is not a bug.
This the correct behaviour as numbers are usually entered in right alignment, where normal text is left aligned (as already pointed out in the discussion)

DenisChenu

DenisChenu

2019-05-22 14:27

developer   ~52046

@c_schmitz : why it's the correct behaviour ?

It's only on Calc or excel for this, and we are on web. Checking on chrome and forefiox : default behaviour of number input is right (in LTR).

I'm OK to close this (really ok), but why it's correct behaviour ?

jelo

jelo

2019-05-24 00:15

partner   ~52098

DenisChenu: I don't need all the options. But LimeSurvey needs a clear vision: What problem should LimeSurvey solve? If LS GmbH states an WYSIWYG-Editor as an important near-term goal, you cannot combine that with alignment of fields via a customized CSS-File. It's not coherent. Jack of all trades will not work.

The "correct" behavior is just the behavior nobody opposed till today.
It's no bug, cause it was an intended move. If it's was aligned in the same way as text, it would be fine too.
So "correct" is the wrong term.

DenisChenu

DenisChenu

2019-05-24 00:22

developer   ~52100

Last edited: 2019-05-24 00:23

View 2 revisions

@jelo :

I don't need all the options.

Yes, but if you search in mantis : all options are asked one time … :).

For template, i use currently CSS class : looking at the screenshot you put about concuurent, some feature need complex code sometimes …

Issue History

Date Modified Username Field Change
2019-05-20 13:02 ninanu New Issue
2019-05-20 18:12 dominikvitt Note Added: 51996
2019-05-22 10:00 ninanu File Added: Unbenannt1.png
2019-05-22 10:00 ninanu File Added: Unbenannt.png
2019-05-22 10:44 jelo Note Added: 52026
2019-05-22 10:46 DenisChenu Note Added: 52027
2019-05-22 11:09 ninanu Note Added: 52030
2019-05-22 11:21 jelo Note Added: 52031
2019-05-22 12:13 DenisChenu Note Added: 52035
2019-05-22 12:18 ninanu Note Added: 52036
2019-05-22 13:22 DenisChenu Note Added: 52043
2019-05-22 13:44 c_schmitz Assigned To => c_schmitz
2019-05-22 13:44 c_schmitz Status new => closed
2019-05-22 13:44 c_schmitz Resolution open => no change required
2019-05-22 13:44 c_schmitz Note Added: 52044
2019-05-22 14:27 DenisChenu Status closed => feedback
2019-05-22 14:27 DenisChenu Resolution no change required => reopened
2019-05-22 14:27 DenisChenu Note Added: 52046
2019-05-24 00:15 jelo Note Added: 52098
2019-05-24 00:22 DenisChenu Note Added: 52100
2019-05-24 00:23 DenisChenu Note Edited: 52100 View Revisions