View Issue Details

IDProjectCategoryView StatusLast Update
14868Bug reports[All Projects] Conditionspublic2019-08-08 17:18
ReporterAkuket Assigned Tocdorin  
PrioritynoneSeveritymajor 
Status closedResolutionunable to reproduce 
Product Version3.17.x 
Target VersionFixed in Version 
Summary14868: Bad apply of conditions on TOKEN:ATTRIBUTE
Description

Hello

When we want to apply conditions on the extra fields of a participant, the behavior of limesurvey is to apply the logical operator "OR" first (which is a good thing). But after that, it is only the "AND" which is used instead of the "OR". Which can not work since it is always the same attribute that is used. Some images may be more meaningful.

Regards

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.17.1+190408
I will donate to the project if issue is resolvedNo
Browserfirefox/chrome
Database & DB-Versionmysql server 5.7.26
Server OS (if known) Ubuntu 16.04.6
Webserver software & version (if known)Apache/2.4.18
PHP Version7.0.33

Activities

Akuket

Akuket

2019-05-09 11:08

reporter  

bug1.PNG (5,124 bytes)
bug1.PNG (5,124 bytes)
bug2.PNG (17,181 bytes)
bug2.PNG (17,181 bytes)
gantier

gantier

2019-05-13 11:43

reporter   ~51915

Hello,
I have the same problem. Is there a workaround we could use ?
Regards.

DenisChenu

DenisChenu

2019-05-15 00:45

developer   ~51937

  1. Please send a sample and light lss file showing this issue
  2. You can always copy/paste good formula in the relevance equation https://manual.limesurvey.org/Expression_Manager#Relevance_.28Controlling_Navigation.2FBranching.29
Akuket

Akuket

2019-05-16 16:37

reporter   ~51969

Hello
Here is the .lss
Thanks



limesurvey_survey_13228.lss (23,594 bytes)
cdorin

cdorin

2019-07-11 16:15

manager   ~52847

Hello @Akuket, FeuilleTpsFrais1 conditions are displayed correctly with "or". Or do you refer to another issue?

cdorin

cdorin

2019-08-08 17:18

manager   ~53153

No feedback provided

Issue History

Date Modified Username Field Change
2019-05-09 11:08 Akuket New Issue
2019-05-09 11:08 Akuket File Added: bug1.PNG
2019-05-09 11:08 Akuket File Added: bug2.PNG
2019-05-13 11:43 gantier Note Added: 51915
2019-05-15 00:45 DenisChenu Note Added: 51937
2019-05-16 16:37 Akuket File Added: limesurvey_survey_13228.lss
2019-05-16 16:37 Akuket Note Added: 51969
2019-07-11 16:15 cdorin Assigned To => cdorin
2019-07-11 16:15 cdorin Status new => feedback
2019-07-11 16:15 cdorin Note Added: 52847
2019-08-08 17:18 cdorin Status feedback => closed
2019-08-08 17:18 cdorin Resolution open => unable to reproduce
2019-08-08 17:18 cdorin Note Added: 53153