View Issue Details

IDProjectCategoryView StatusLast Update
14825Bug reports[All Projects] Otherpublic2019-05-10 15:36
Reporterdominikvitt Assigned ToDenisChenu  
PrioritynoneSeverityblock 
Status closedResolutionunable to reproduce 
Product Version4.0.0dev 
Target Version4.0.0-betaFixed in Version4.0.0dev 
Summary14825: Unable to activate survey
Description

When trying to activate survey, following error message is shown:
CDbCommand failed to execute the SQL statement: SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1. The SQL statement executed was: SET default_storage_engine=;

See attached file.

Steps To Reproduce

Try to activate survey.

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.0.0-alpha
I will donate to the project if issue is resolvedNo
BrowserChromium, Firefox
Database & DB-VersionMySQL 5.7.24-0ubuntu0.18.04.1
Server OS (if known)Linux Mint 19.2 Tara 64-bit
Webserver software & version (if known)Nginx
PHP Version7.2.17-1+ubuntu18.04.1+deb.sury.org+3

Activities

dominikvitt

dominikvitt

2019-04-30 09:37

developer  

CDbException.html (22,549 bytes)
TonisOrmisson

TonisOrmisson

2019-05-01 15:18

developer   ~51708

a clean install of 4.0?
seems like not and mysqlEngine' param missing from config.php

maybe the mysqlEngine should be duplicated in config/internal for fallback in case of non-clean install

DenisChenu

DenisChenu

2019-05-02 08:00

developer   ~51709

maybe the mysqlEngine should be duplicated in config/internal for fallback in case of non-clean install

Surely then ;)

dominikvitt

dominikvitt

2019-05-02 11:01

developer   ~51715

I'm not able to reproduce this issue on clean install.

DenisChenu

DenisChenu

2019-05-02 11:04

developer   ~51716

But need tesiting with update too ? No ?

TonisOrmisson

TonisOrmisson

2019-05-02 11:12

developer   ~51718

adding mysqlEngine to internal conf should be done anyway.

DenisChenu

DenisChenu

2019-05-02 11:16

developer   ~51719

Or , in function setMySQLDefaultEngine : checking if param is not empty (and is valid for current DB) : maybe better , no ?

DenisChenu

DenisChenu

2019-05-02 11:25

developer   ~51721

https://github.com/LimeSurvey/LimeSurvey/commit/5816d10af42e69e11289d999187133f8fc569ca4

I check only inside models

c_schmitz

c_schmitz

2019-05-10 15:36

administrator   ~51876

4.0beta1 released

Issue History

Date Modified Username Field Change
2019-04-30 09:37 dominikvitt New Issue
2019-04-30 09:37 dominikvitt File Added: CDbException.html
2019-05-01 15:18 TonisOrmisson Note Added: 51708
2019-05-02 08:00 DenisChenu Note Added: 51709
2019-05-02 11:01 dominikvitt Assigned To => dominikvitt
2019-05-02 11:01 dominikvitt Status new => resolved
2019-05-02 11:01 dominikvitt Resolution open => unable to reproduce
2019-05-02 11:01 dominikvitt Note Added: 51715
2019-05-02 11:04 DenisChenu Note Added: 51716
2019-05-02 11:12 TonisOrmisson Note Added: 51718
2019-05-02 11:16 DenisChenu Note Added: 51719
2019-05-02 11:17 DenisChenu Assigned To dominikvitt => DenisChenu
2019-05-02 11:17 DenisChenu Status resolved => assigned
2019-05-02 11:25 DenisChenu Note Added: 51721
2019-05-02 11:25 DenisChenu Status assigned => resolved
2019-05-02 11:25 DenisChenu Fixed in Version => 4.0.0dev
2019-05-10 15:36 c_schmitz Note Added: 51876
2019-05-10 15:36 c_schmitz Status resolved => closed