View Issue Details

IDProjectCategoryView StatusLast Update
14794Bug reports[All Projects] Survey participants (Tokens)public2019-05-10 15:36
ReporterDenisChenuAssigned Todominikvitt 
PrioritynoneSeverityminor 
Status closedResolutionunable to reproduce 
Product Version4.0.0dev 
Target VersionFixed in Version 
Summary14794: Token are not set to "sended" after email sent
Description

When sending email, if table is encrypted : token are not set to Sended with date

Steps To Reproduce

See Description

Additional Information

I think we must use afterFind and beforeSave event to automatically encrypt and decrot value

The issue is (partially) fixed here : https://github.com/LimeSurvey/LimeSurvey/pull/1268/files#diff-091a0a33007efec2513a2239ea06c9ebR1455
But since its SURELY a partial fix, usng a afterFind and beforeSave event fix in all condition.

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.0.0 github
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionmariadb
Server OS (if known)fedora/linux
Webserver software & version (if known)nginx
PHP Versionphp7.2

Relationships

related to 14795 assigneddominikvitt Development  Extend Token Response etc … to automatically encryt/decrypt 

Activities

dominikvitt

dominikvitt

2019-04-24 13:56

developer   ~51569

Works as expected.

DenisChenu

DenisChenu

2019-04-24 14:15

developer   ~51570

? What ????

I just check this morning : i send the LSA : email was not SET to sended after send

DenisChenu

DenisChenu

2019-04-24 14:22

developer   ~51571

Arg right … another issue before

c_schmitz

c_schmitz

2019-05-10 15:36

administrator   ~51882

4.0beta1 released

Issue History

Date Modified Username Field Change
2019-04-24 10:37 DenisChenu New Issue
2019-04-24 10:37 DenisChenu Status new => assigned
2019-04-24 10:37 DenisChenu Assigned To => dominikvitt
2019-04-24 10:51 DenisChenu Relationship added related to 14795
2019-04-24 13:56 dominikvitt Status assigned => resolved
2019-04-24 13:56 dominikvitt Resolution open => unable to reproduce
2019-04-24 13:56 dominikvitt Note Added: 51569
2019-04-24 14:15 DenisChenu Note Added: 51570
2019-04-24 14:22 DenisChenu Note Added: 51571
2019-05-10 15:36 c_schmitz Note Added: 51882
2019-05-10 15:36 c_schmitz Status resolved => closed