View Issue Details

IDProjectCategoryView StatusLast Update
14749Bug reports[All Projects] Survey designpublic2019-06-13 13:45
ReporterDenisChenuAssigned Todominikvitt 
PrioritynoneSeverityminor 
Status resolvedResolutionfixed 
Product Version4.0.0dev 
Target VersionFixed in Version4.0.0-beta 
Summary14749: Unable to move questions
Description

See screenshot

Additional Information

Move to organize question, move one question, save and see what happen

TagsNo tags attached.
Complete LimeSurvey version number (& build)
I will donate to the project if issue is resolved
Browser
Database & DB-Version
Server OS (if known)
Webserver software & version (if known)
PHP Version

Activities

DenisChenu

DenisChenu

2019-04-06 14:57

developer  

Error.html (19,134 bytes)
cdorin

cdorin

2019-04-10 17:47

manager   ~51434

When is this happening? Can't reproduce it on my local/pro instance

DenisChenu

DenisChenu

2019-04-12 10:37

developer   ~51446

Oups : 4.0

dominikvitt

dominikvitt

2019-06-12 17:54

developer   ~52375

Question moving works as expected using latest LS version 4.0.0-beta, no error message.

DenisChenu

DenisChenu

2019-06-12 17:56

developer   ~52376

Last edited: 2019-06-12 17:57

View 2 revisions

@dominikvitt using last GIT for develop : no save buttons on organize.

maybe you spoke from another screen ? Way to reorder ?

Linl index.php?r=admin/survey/sa/organize&surveyid=XXXX found in menu

DenisChenu

DenisChenu

2019-06-12 17:56

developer  

DenisChenu

DenisChenu

2019-06-12 17:57

developer  

dominikvitt

dominikvitt

2019-06-12 18:01

developer   ~52377

There is no error message, but "Save" button is missing.
I'll look into it.

DenisChenu

DenisChenu

2019-06-12 18:06

developer   ~52378

No save button : no way to save => no error message ;)

dominikvitt

dominikvitt

2019-06-13 13:45

developer   ~52396

This issue is fixed.
The patch is available now on GitHub and would be available on next LimeSurvey release.

https://github.com/LimeSurvey/LimeSurvey/commit/149bfccc615990da90fbdda0c2004093c40f7f69

Issue History

Date Modified Username Field Change
2019-04-06 14:57 DenisChenu New Issue
2019-04-06 14:57 DenisChenu File Added: Capture d’écran du 2019-04-06 14-54-30.png
2019-04-06 14:57 DenisChenu File Added: Error.html
2019-04-10 17:47 cdorin Note Added: 51434
2019-04-12 10:37 DenisChenu Note Added: 51446
2019-04-12 10:37 DenisChenu Product Version => 4.0.0dev
2019-06-12 17:54 dominikvitt Assigned To => dominikvitt
2019-06-12 17:54 dominikvitt Status new => resolved
2019-06-12 17:54 dominikvitt Resolution open => unable to reproduce
2019-06-12 17:54 dominikvitt Note Added: 52375
2019-06-12 17:56 DenisChenu Status resolved => feedback
2019-06-12 17:56 DenisChenu Resolution unable to reproduce => reopened
2019-06-12 17:56 DenisChenu Note Added: 52376
2019-06-12 17:56 DenisChenu File Added: Capture d’écran du 2019-06-12 17-55-50.png
2019-06-12 17:57 DenisChenu Note Edited: 52376 View Revisions
2019-06-12 17:57 DenisChenu File Added: Capture d’écran du 2019-06-12 17-57-39.png
2019-06-12 17:58 DenisChenu Project Feature requests => Bug reports
2019-06-12 17:58 DenisChenu Severity feature => minor
2019-06-12 18:01 dominikvitt Note Added: 52377
2019-06-12 18:06 DenisChenu Note Added: 52378
2019-06-12 18:06 DenisChenu Status feedback => assigned
2019-06-13 13:45 dominikvitt Status assigned => resolved
2019-06-13 13:45 dominikvitt Resolution reopened => fixed
2019-06-13 13:45 dominikvitt Fixed in Version => 4.0.0-beta
2019-06-13 13:45 dominikvitt Note Added: 52396