View Issue Details

IDProjectCategoryView StatusLast Update
14699Bug reports[All Projects] Translationpublic2019-04-02 16:42
ReporterGuernseyResearch Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.16.x 
Target VersionFixed in Version3.17.x 
Summary14699: Start popups add , between string
Description

spacing error in translated error message

Steps To Reproduce

incorrect upload of a file

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.16.0+190225
I will donate to the project if issue is resolvedNo
Browserfirefox
Database & DB-Versionn/a
Server OS (if known)
Webserver software & version (if known)
PHP Versionn/a

Activities

GuernseyResearch

GuernseyResearch

2019-03-27 14:52

reporter  

Pop-Up error.png (127,115 bytes)
cdorin

cdorin

2019-03-29 17:15

manager   ~51206

Hey @GuernseyResearch. Thanks for spotting the mistake!

It is a translation mistake. Could you please correct it here: https://translate.limesurvey.org/projects/limesurvey-3/? Use your limesurvey.org credentials to log in.

GuernseyResearch

GuernseyResearch

2019-03-29 21:01

reporter   ~51213

I went to do the edit and it appears that the problem is not the translation, but the concatenation of the two error messages that make up the popup message. I was unable to fix it. Note, this is a VERY MINOR problem.

DenisChenu

DenisChenu

2019-03-30 09:08

developer   ~51214

@GuernseyResearch : since you find one of the sentence on translate : can you copy/paste one of the englis sentece ?
I can, check it and see if i find a good solution.

GuernseyResearch

GuernseyResearch

2019-03-30 16:15

reporter   ~51216

The first error is : One or more questions have not been answered in a valid manner. You cannot proceed until these answers are valid.
then the popup adds: One or more file have either exceeded the filesize/are not in the right format or the minimum number of required files have not been uploaded. You cannot proceed until these have been completed

This popup occurs when someone is doing a file upload. It appear that there is a missing space and an extra comma when the two parts are joined together to great the popup error message.



Pop-Up error-2.png (127,115 bytes)
DenisChenu

DenisChenu

2019-03-30 18:14

developer   ~51219

OK, file upload question then



DenisChenu

DenisChenu

2019-03-30 18:16

developer  

limesurvey_survey_uàload.lss (19,611 bytes)
DenisChenu

DenisChenu

2019-03-30 18:44

developer   ~51220

JS issue here . Set popup on page fix the issue.



DenisChenu

DenisChenu

2019-03-30 20:06

developer   ~51225

https://github.com/LimeSurvey/LimeSurvey/commit/1c914f94ebfed15f00b9c664cd190f39042650e2
and
https://github.com/LimeSurvey/LimeSurvey/commit/97d2f8e80c78e487794e6278bb7bf805c062427f

Issue History

Date Modified Username Field Change
2019-03-27 14:52 GuernseyResearch New Issue
2019-03-27 14:52 GuernseyResearch File Added: Pop-Up error.png
2019-03-29 17:15 cdorin Note Added: 51206
2019-03-29 17:15 cdorin Status new => confirmed
2019-03-29 21:01 GuernseyResearch Note Added: 51213
2019-03-30 09:08 DenisChenu Note Added: 51214
2019-03-30 16:15 GuernseyResearch File Added: Pop-Up error-2.png
2019-03-30 16:15 GuernseyResearch Note Added: 51216
2019-03-30 18:14 DenisChenu File Added: Capture d’écran du 2019-03-30 18-13-50.png
2019-03-30 18:14 DenisChenu Note Added: 51219
2019-03-30 18:16 DenisChenu File Added: limesurvey_survey_uàload.lss
2019-03-30 18:44 DenisChenu File Added: Capture d’écran du 2019-03-30 18-44-11.png
2019-03-30 18:44 DenisChenu Note Added: 51220
2019-03-30 19:47 DenisChenu Assigned To => DenisChenu
2019-03-30 19:47 DenisChenu Status confirmed => assigned
2019-03-30 19:48 DenisChenu Summary minor typo in translated error popup => Start popups add , between string
2019-03-30 20:06 DenisChenu Status assigned => resolved
2019-03-30 20:06 DenisChenu Resolution open => fixed
2019-03-30 20:06 DenisChenu Fixed in Version => 3.16.x
2019-03-30 20:06 DenisChenu Note Added: 51225
2019-04-02 16:42 ollehar Status resolved => closed
2019-04-02 16:42 ollehar Fixed in Version 3.16.x => 3.17.x