View Issue Details

IDProjectCategoryView StatusLast Update
14682Bug reports[All Projects] Survey designpublic2019-04-02 16:41
ReporterDenisChenu Assigned ToDenisChenu  
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version3.16.x 
Target VersionFixed in Version3.17.x 
Summary14682: When deactivation survey with debug 1 : receive a CDbException
Description

There are situation where when admin user can receive a CDbException when deactivate survey

Steps To Reproduce

I try to reproduce but after have it 3 times … i can't find the complete way to reproduce (set debug to 0, reset to 1)…
But see the CDbException file

When i get back with browser : i see the alert «survey can not be dectaviated because it's not activated) : survey seems deactivate OK.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.16.1 github
I will donate to the project if issue is resolvedNo
Browsernot relevant (FF)
Database & DB-Versionmariadb
Server OS (if known)fedora/linux and debian/linux
Webserver software & version (if known)nginx and apache2
PHP Versionphp7.2

Issue History

Date Modified Username Field Change
2019-03-23 18:07 DenisChenu New Issue
2019-03-23 18:07 DenisChenu File Added: CDbException.html
2019-03-23 18:10 DenisChenu Steps to Reproduce Updated View Revisions
2019-03-30 19:46 DenisChenu Assigned To => DenisChenu
2019-03-30 19:46 DenisChenu Status new => assigned
2019-03-30 20:05 DenisChenu Status assigned => resolved
2019-03-30 20:05 DenisChenu Resolution open => fixed
2019-03-30 20:05 DenisChenu Fixed in Version => 3.16.x
2019-03-30 20:05 DenisChenu Note Added: 51224
2019-04-02 16:41 ollehar Status resolved => closed
2019-04-02 16:41 ollehar Fixed in Version 3.16.x => 3.17.x