View Issue Details

IDProjectCategoryView StatusLast Update
14604Bug reports[All Projects] Survey designpublic2019-06-28 12:27
ReporterDenisChenuAssigned Top_teichmann 
PriorityhighSeverityminor 
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.17.x 
Summary14604: Survey settings menu disappear
Description

Update number of question shown in question list remove Survey settings menu

Steps To Reproduce

Go to question list
Set display to 5 (or 20
Look at the left menu : Surveysettings are removed

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.16.1 github
I will donate to the project if issue is resolvedNo
BrowserFF
Database & DB-Versionmariadb
Server OS (if known)fedora/linux
Webserver software & version (if known)nginx
PHP Versionphp7.2

Activities

DenisChenu

DenisChenu

2019-03-05 16:38

developer  

simplescreenrecorder-2019-03-05_16.34.28.webm (565,904 bytes)
cdorin

cdorin

2019-03-05 17:01

manager   ~50782

Yes, I can confirm it and it is quite annoying. I will talk to markus when he will be available

cdorin

cdorin

2019-06-24 14:57

manager   ~52504

@p_teichmann, were you working on this one? (don't remember exactly). Find the issue important since it s something related to frontend/what users see when they access the sfotware.

p_teichmann

p_teichmann

2019-06-26 14:18

developer   ~52565

Last edited: 2019-06-26 14:19

View 2 revisions

i wasnt working on it but i fixed in https://github.com/LimeSurvey/LimeSurvey/commit/ff061148dcc44d9e07000276c046e82bbed737af

p_teichmann

p_teichmann

2019-06-28 12:27

developer   ~52620

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=28999

Related Changesets

LimeSurvey: master ff061148

2019-06-26 14:15:01

p_teichmann

Details Diff
Fixed issue 14604: fixed invalid ajaxUpdate setting "true" causing issues for other scripts Affected Issues
14604
mod - application/extensions/admin/survey/ListSurveysWidget/views/listSurveys.php Diff File
mod - application/views/admin/labels/labelsets_view.php Diff File
mod - application/views/admin/notification/index.php Diff File
mod - application/views/admin/responses/browsetimerow_view.php Diff File
mod - application/views/admin/survey/Question/listquestions.php Diff File
mod - application/views/admin/survey/QuestionGroups/listquestiongroups.php Diff File
mod - application/views/admin/surveymenu/index.php Diff File
mod - application/views/admin/surveymenu/shortlist.php Diff File
mod - application/views/admin/surveymenu_entries/shortlist.php Diff File
mod - application/views/admin/token/browse.php Diff File
mod - application/views/admin/tutorials/index.php Diff File
mod - application/views/admin/usergroup/usergroups_view.php Diff File

Issue History

Date Modified Username Field Change
2019-03-05 16:38 DenisChenu New Issue
2019-03-05 16:38 DenisChenu File Added: simplescreenrecorder-2019-03-05_16.34.28.webm
2019-03-05 17:01 cdorin Priority none => high
2019-03-05 17:01 cdorin Status new => confirmed
2019-03-05 17:01 cdorin Note Added: 50782
2019-06-24 14:57 cdorin Assigned To => p_teichmann
2019-06-24 14:57 cdorin Status confirmed => assigned
2019-06-24 14:57 cdorin Note Added: 52504
2019-06-26 14:18 p_teichmann Status assigned => resolved
2019-06-26 14:18 p_teichmann Resolution open => fixed
2019-06-26 14:18 p_teichmann Fixed in Version => 3.17.x
2019-06-26 14:18 p_teichmann Note Added: 52565
2019-06-26 14:19 p_teichmann Note Edited: 52565 View Revisions
2019-06-28 12:27 p_teichmann Changeset attached => LimeSurvey master ff061148
2019-06-28 12:27 p_teichmann Note Added: 52620