View Issue Details

IDProjectCategoryView StatusLast Update
14548Bug reports[All Projects] _ Unknownpublic2019-04-30 09:11
ReporterrealitixAssigned Todominikvitt 
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version3.15.x 
Target VersionFixed in Version3.15.x 
Summary14548: PHP error with Question L with public statistic
Description

Hello,

I found a bug in the statistic computation for the public part.
I'm sending the pull request to fix it.

It's similar to bug 14547.

Steps To Reproduce
  1. Put limesurvey in debug mode (mandatory)
  2. Create a survey with only one group and one question of type L (radio button)
  3. Fill subquestion like this:

A1 ; Question 1
A2 ; Question 2
A3 ; Question 3
A4 ; Question 4
Autre ; Question buggée

  1. Enable public statistic for this question
  2. Activate the survey and fill it several times
  3. Start the survey and show statistic at the end

Php Crash!

TagsNo tags attached.
Complete LimeSurvey version number (& build)master 3.15.9
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Version0
Server OS (if known)
Webserver software & version (if known)
PHP Version0

Relationships

related to 14547 closeddominikvitt PHP error with Question L on statistic page with simple mode 

Activities

realitix

realitix

2019-02-19 10:19

reporter   ~50618

Here the pull request: https://github.com/LimeSurvey/LimeSurvey/pull/1226

dominikvitt

dominikvitt

2019-02-19 18:24

developer   ~50640

I'm unable to reproduce this issue.
Please upload test .lsa or .lss file.

realitix

realitix

2019-02-22 11:19

reporter   ~50667

Hello, Here the .lss file



limesurvey_survey_616274.lss (16,973 bytes)
realitix

realitix

2019-02-22 11:19

reporter   ~50668

Don't forget to put Limesurvey in debug

jelo

jelo

2019-02-22 13:33

partner   ~50670

Last edited: 2019-02-22 13:33

View 2 revisions

It's not very helpful that PHP version is 0. Please provide infos about your environment.

realitix

realitix

2019-02-22 14:01

reporter   ~50671

My PHP VERSION: 5.5.9-1ubuntu4.26

I can't edit the issue.

dominikvitt

dominikvitt

2019-02-22 14:33

developer   ~50673

PR is merged.
https://github.com/LimeSurvey/LimeSurvey/commit/b0911484da79f70a6641a0213994ff1b4a5d7cf3

Issue History

Date Modified Username Field Change
2019-02-19 10:17 realitix New Issue
2019-02-19 10:19 realitix Note Added: 50618
2019-02-19 18:24 dominikvitt Note Added: 50640
2019-02-22 11:19 realitix File Added: limesurvey_survey_616274.lss
2019-02-22 11:19 realitix Note Added: 50667
2019-02-22 11:19 realitix Note Added: 50668
2019-02-22 12:15 DenisChenu Relationship added related to 14547
2019-02-22 13:33 jelo Note Added: 50670
2019-02-22 13:33 jelo Note Edited: 50670 View Revisions
2019-02-22 14:01 realitix Note Added: 50671
2019-02-22 14:17 dominikvitt Assigned To => dominikvitt
2019-02-22 14:17 dominikvitt Status new => assigned
2019-02-22 14:21 dominikvitt Status assigned => confirmed
2019-02-22 14:33 dominikvitt Status confirmed => resolved
2019-02-22 14:33 dominikvitt Resolution open => fixed
2019-02-22 14:33 dominikvitt Fixed in Version => 3.15.x
2019-02-22 14:33 dominikvitt Note Added: 50673
2019-04-30 09:11 c_schmitz Status resolved => closed