View Issue Details

IDProjectCategoryView StatusLast Update
14498Bug reports[All Projects] Print Viewpublic2019-02-12 15:03
ReporterritapasAssigned Todominikvitt 
PrioritynoneSeverityminor 
Status resolvedResolutionfixed 
Product Version3.15.x 
Target VersionFixed in Version3.15.x 
Summary14498: Participant view for statistics goes unformatted
Description

The participant view for statistics is shown without formatting.

Steps To Reproduce

Create a survey and enable public statistics for some of its questions.
Run it as a participant and show statisticts.
This happens with Vanilla, Fruity and Bootstrap themes,

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.15.5+181115
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Version MariaDB 5.5.60
Server OS (if known)
Webserver software & version (if known)
PHP Versionrh-php71-1-1

Activities

ritapas

ritapas

2019-02-07 10:52

reporter  

LS_ViewStatistics.PNG (17,655 bytes)
LS_ViewStatistics.PNG (17,655 bytes)
dominikvitt

dominikvitt

2019-02-07 17:05

developer   ~50446

I managed to style it better (but not perfect yet), please write your comments below.



ritapas

ritapas

2019-02-07 19:58

reporter   ~50448

It is better of course, even tough I don't like serif fonts in this context. Is this something you achieved by working on themes? Sorry if this is a dumb question but I must say twig is puzzling me a lot and I just couldn't get the hang of it yet.

DenisChenu

DenisChenu

2019-02-08 09:25

developer   ~50449

My point of view:

  1. Maybe it's better to use boostrap class ?
  2. Must remove usage of col-sm-X : since tcpdf is not compatible with float : https://bugs.limesurvey.org/view.php?id=14353
  3. I think the best is to use a table in core

See https://gitlab.com/SondagesPro/SurveyThemes/skelvanilla/tree/master/views/subviews/printanswers ( but no time to fix whole question …)

dominikvitt

dominikvitt

2019-02-08 11:03

developer   ~50451

User statistics page is rendered inside of user statistics helper, so no theme, twig or CSS files are used.
This page isn't scheduled to be rebuilt right now, although it may be rebuilt some time in the future.
So for now, I would just create a commit with changes to make it look nicer (as is showed in screenshot I showed).

dominikvitt

dominikvitt

2019-02-08 11:08

developer   ~50452

https://github.com/LimeSurvey/LimeSurvey/commit/6bc3d9ff9ba95a0d3393ee4eed9185286311513d

ritapas

ritapas

2019-02-08 11:10

reporter   ~50453

thanks

DenisChenu

DenisChenu

2019-02-08 11:11

developer   ~50454

Oups sorry @dominikvitt … my error print view against public statistics

Issue History

Date Modified Username Field Change
2019-02-07 10:52 ritapas New Issue
2019-02-07 10:52 ritapas File Added: LS_ViewStatistics.PNG
2019-02-07 16:02 dominikvitt Assigned To => dominikvitt
2019-02-07 16:02 dominikvitt Status new => assigned
2019-02-07 17:05 dominikvitt File Added: Screenshot_2019-02-07_17-01-59.png
2019-02-07 17:05 dominikvitt Note Added: 50446
2019-02-07 19:58 ritapas Note Added: 50448
2019-02-08 09:25 DenisChenu Note Added: 50449
2019-02-08 09:25 DenisChenu Relationship added related to 14353
2019-02-08 11:03 dominikvitt Note Added: 50451
2019-02-08 11:08 dominikvitt Status assigned => resolved
2019-02-08 11:08 dominikvitt Resolution open => fixed
2019-02-08 11:08 dominikvitt Fixed in Version => 3.15.x
2019-02-08 11:08 dominikvitt Note Added: 50452
2019-02-08 11:10 ritapas Note Added: 50453
2019-02-08 11:11 DenisChenu Note Added: 50454
2019-02-12 15:03 DenisChenu Relationship deleted related to 14353