View Issue Details

IDProjectCategoryView StatusLast Update
14487Bug reports[All Projects] Survey takingpublic2019-04-30 09:11
Reporteraserto Assigned ToDenisChenu  
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version3.15.x 
Target VersionFixed in Version3.15.x 
Summary14487: While UPDATING ti V 3.15.X End-URL doesn't work correctly
Description

After upgrading from V 2.72.X to V 3.15.X my studies have problems to process correct ‘END-URLs’. Normally I use ‘End-URL’ to transfer attributes from one study to another, but actually it doesn’t work correctly.

• If I use an ‘IF-Statement’ to choose the correct following study, the process stopped because of having unexpected symbols like: “&”+”quot” OR “&”+”amp”. Same problem was reported here - without a solution: https://bugs.limesurvey.org/view.php?id=14110

• If I use a static route to a fixed study everything works correctly in the first step. But at the end of the second study, I normally use again an ‘End-URL’ to jump back into the first study and open a new case (circle), I again get a new ‘URL-transport-problem’: For every ‘text/string’-attribute a“<span id='LEMtailor_Q_0_3'>MY TEXT</span>” is added.

  1. The Limesurvey-Answer-View doesn’t show these additional symbols. I first detected the failure when inspecting an export.

  2. If I tried to commit one of the filled values to the next study by using the ‘End-URL’, I get an Error.

Do you have any idea how to fix the syntax-problem?

Steps To Reproduce

You can reproduce my errors by using our testbed: https://tu.aserto-analyse.de/index.php/489658?lang=de

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.15.8
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionMySQL
Server OS (if known)
Webserver software & version (if known)
PHP Version7.2

Relationships

related to 14113 confirmedLouisGac Ampersands are changed to & 
related to 14110 assignedLouisGac Redirection Url stores & marks as & 

Activities

DenisChenu

DenisChenu

2019-02-05 08:16

developer   ~50401

Please, give a lss file

aserto

aserto

2019-02-05 10:49

reporter   ~50404

Here you are.



Test002_limesurvey_survey.lss (21,473 bytes)
Test001_limesurvey_survey.lss (20,506 bytes)
DenisChenu

DenisChenu

2019-02-05 12:11

developer   ~50406

Confirm issue with core theme

DenisChenu

DenisChenu

2019-02-05 13:11

developer   ~50408

https://github.com/LimeSurvey/LimeSurvey/commit/b2eba0d649ea8477bd809191c403d7f64325e672

aserto

aserto

2019-02-05 14:17

reporter   ~50410

Great, you made my day! The main problem is fixed.

Unfortunately your excellent solution doesn't fix the second side of the URL-Problem completely:
"If I use an ‘IF-Statement’ to choose the correct following study, the process stopped because of having unexpected symbols like: “&”+”quot” OR “&”+”amp”. Same problem was reported here - without a solution: https://bugs.limesurvey.org/view.php?id=14110&quot;

On the surface it looks well, but if you try to use the syntax, an error occurs (see attached photo).



UrlProblematikTeil2.JPG (84,987 bytes)
UrlProblematikTeil2.JPG (84,987 bytes)
aserto

aserto

2019-02-07 10:05

reporter   ~50429

Great, you made my day! The main problem is fixed.

Unfortunately your excellent solution doesn't fix the second side of the URL-Problem completely:
"If I use an ‘IF-Statement’ to choose the correct following study, the process stopped because of having unexpected symbols like: “&”+”quot” OR “&”+”amp”. Same problem was reported here - without a solution: https://bugs.limesurvey.org/view.php?id=14110&quot;

On the surface it looks well, but if you try to use the syntax, an error occurs (see attached photo).

DenisChenu

DenisChenu

2019-02-07 10:29

developer   ~50430

For workaround (a workaround i use for years) : use an equation question type for endurl.

  1. No issue like this
  2. Really more easy to do a complex equation
  3. Really more easy to check expression validity.

But, here : the initial issue uis fixed. Please : report another issue (or comment on previous one).

Issue History

Date Modified Username Field Change
2019-02-04 16:46 aserto New Issue
2019-02-05 08:16 DenisChenu Note Added: 50401
2019-02-05 10:49 aserto File Added: Test002_limesurvey_survey.lss
2019-02-05 10:49 aserto File Added: Test001_limesurvey_survey.lss
2019-02-05 10:49 aserto Note Added: 50404
2019-02-05 12:11 DenisChenu Note Added: 50406
2019-02-05 12:11 DenisChenu Assigned To => DenisChenu
2019-02-05 12:11 DenisChenu Status new => assigned
2019-02-05 13:11 DenisChenu Status assigned => resolved
2019-02-05 13:11 DenisChenu Resolution open => fixed
2019-02-05 13:11 DenisChenu Fixed in Version => 3.15.x
2019-02-05 13:11 DenisChenu Note Added: 50408
2019-02-05 14:17 aserto File Added: UrlProblematikTeil2.JPG
2019-02-05 14:17 aserto Note Added: 50410
2019-02-07 10:05 aserto Status resolved => feedback
2019-02-07 10:05 aserto Resolution fixed => reopened
2019-02-07 10:05 aserto Note Added: 50429
2019-02-07 10:29 DenisChenu Note Added: 50430
2019-02-07 10:29 DenisChenu Status feedback => resolved
2019-02-07 10:29 DenisChenu Resolution reopened => fixed
2019-02-07 10:48 Mazi Relationship added child of 14113
2019-03-18 09:50 Mazi Relationship added related to 14110
2019-03-18 09:50 Mazi Relationship replaced related to 14113
2019-04-30 09:11 c_schmitz Status resolved => closed