View Issue Details

IDProjectCategoryView StatusLast Update
14456Bug reports[All Projects] Response browsingpublic2019-06-11 02:12
ReporterMaziAssigned Top_teichmann 
PriorityhighSeverityminor 
Status resolvedResolutionfixed 
Product Version3.15.x 
Target Version3.16.xFixed in Version3.17.x 
Summary14456: Regression: Feature for selecting which data columsn to show was removed after Limesurvey 2.6 LTS
Description

The response overview at Limesurvey v2.6 LTS had a great feature. At the bottom of the table one could click an icon to select the columns which should be show at the tabular overview (see screenshot). Unfortunately, that feature is now missing at Limesurvey 3.x. It would be a great benefit to re-add this.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.15.6+190108
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-VersionMySQL 5
Server OS (if known)Ubuntu 14 TLS
Webserver software & version (if known)Apache 2
PHP Version7.0.26

Activities

Mazi

Mazi

2019-01-28 15:19

partner  

column_filter_ls2.6.png (26,219 bytes)
column_filter_ls2.6.png (26,219 bytes)
Mazi

Mazi

2019-01-28 15:22

partner   ~50329

@markusfluer: I am assigning this one to you since it seems to be a task for a JavaScript expert. Let me know if you need any further details.

p_teichmann

p_teichmann

2019-05-31 13:31

administrator   ~52254

fixed in https://github.com/LimeSurvey/LimeSurvey/commit/1455c56843e5556ce4836a4a15893a0dca838789

p_teichmann

p_teichmann

2019-06-03 17:03

administrator   ~52280

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=28988

Mazi

Mazi

2019-06-10 16:33

partner   ~52339

@p_teichmann, please don't forget updating the manual with some details about that feature if needed.
Thanks!

DenisChenu

DenisChenu

2019-06-11 02:12

developer   ~52341

@p_teichmann :
Can't hide id : OK
Can't hide seed : Not OK (in my opinion)

Thanks :)

Related Changesets

LimeSurvey: master 1455c568

2019-05-31 12:22:37

p_teichmann

Details Diff
Fixed issue 14456: Regression: Feature for selecting which data columsn to show was removed after Limesurvey 2.6 LTS Affected Issues
14456
mod - application/controllers/admin/responses.php Diff File
mod - application/extensions/admin/grid/MassiveActionsWidget/views/selector.php Diff File
mod - application/views/admin/responses/listResponses_view.php Diff File
add - application/views/admin/responses/modal_subviews/filterColumns.php Diff File
mod - assets/scripts/admin/listresponse.js Diff File
mod - assets/styles-public/browse.css Diff File

Issue History

Date Modified Username Field Change
2019-01-28 15:19 Mazi New Issue
2019-01-28 15:19 Mazi Status new => assigned
2019-01-28 15:19 Mazi Assigned To => markusfluer
2019-01-28 15:19 Mazi File Added: column_filter_ls2.6.png
2019-01-28 15:22 Mazi Note Added: 50329
2019-02-05 15:25 c_schmitz Reproducibility have not tried => always
2019-02-05 15:25 c_schmitz Summary Feature for selecting which data columsn to show was removed after Limesurvey 2.6 LTS => Regression: Feature for selecting which data columsn to show was removed after Limesurvey 2.6 LTS
2019-02-05 15:31 c_schmitz Priority none => high
2019-05-07 16:02 c_schmitz Assigned To markusfluer => p_teichmann
2019-05-31 13:31 p_teichmann Note Added: 52254
2019-05-31 13:32 p_teichmann Status assigned => resolved
2019-05-31 13:32 p_teichmann Resolution open => fixed
2019-05-31 13:32 p_teichmann Fixed in Version => 3.17.x
2019-06-03 17:03 p_teichmann Changeset attached => LimeSurvey master 1455c568
2019-06-03 17:03 p_teichmann Note Added: 52280
2019-06-10 16:33 Mazi Note Added: 52339
2019-06-11 02:12 DenisChenu Note Added: 52341