View Issue Details

IDProjectCategoryView StatusLast Update
14439Bug reports[All Projects] Theme editorpublic2019-04-02 16:41
ReporterDenisChenuAssigned Todominikvitt 
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.15.x 
Target VersionFixed in Version3.17.x 
Summary14439: More button and action than available according Permission in theme
Description

An user with only "view" theme have a lot of action button and this action button can give error

Steps To Reproduce

Create an user with Them /view only
Connect with this user
Go to theme

Additional Information

Before fixing "disable/hide" button :

  1. Reset goes to a white page : must redirect or show a 401
  2. Uninstall : redirect with alert (401 ?)
  3. Install : redirect with alert (401 ?)
  4. Copy : don't copy BUT redirect to the original : must redirect to list ? Or show a 401
  5. Theme options : redirect with alert (401 ?)
  6. Theme editor (user) : show theme without buttons : Ok
  7. Theme editor (global) : show theme without buttons : Ok BUIT with the copy link
TagsNo tags attached.
Complete LimeSurvey version number (& build)3.15.6 github
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Activities

DenisChenu

DenisChenu

2019-01-18 11:06

developer  

dominikvitt

dominikvitt

2019-04-01 17:33

developer   ~51252

This issue is fixed:
https://github.com/LimeSurvey/LimeSurvey/commit/f20abfe8d11d3dc1210b36982e3565a6d7fbbb52

Survey and global theme pages were already fixed before.
This is fix to hide buttons on survey group theme page.
Permission check for those buttons is also implemented, so user can't use direct links.

DenisChenu

DenisChenu

2019-04-01 17:38

developer   ~51254

Question : what about Copy ?
I think READ allow copy/extend
No ?

dominikvitt

dominikvitt

2019-04-01 17:55

developer   ~51258

"Create template" permission is required to extend template, so I'll change it so it shows that button for "create" permission.

DenisChenu

DenisChenu

2019-04-01 17:56

developer   ~51259

Upis right : read THIS template + Create new one :)

DenisChenu

DenisChenu

2019-04-01 18:58

developer   ~51262

Last edited: 2019-04-01 18:58

View 2 revisions

@dominikvitt : since there are not real Permission settings for template : think it's OK in 3.X

I add a real Permission settings in 4.0 feature request

Else : user Copy a survey but can not update the new copied survey …

Issue History

Date Modified Username Field Change
2019-01-18 11:06 DenisChenu New Issue
2019-01-18 11:06 DenisChenu File Added: Capture d’écran du 2019-01-18 11-00-14.png
2019-01-18 11:06 DenisChenu File Added: Capture d’écran du 2019-01-18 11-01-03.png
2019-02-07 16:12 dominikvitt Assigned To => dominikvitt
2019-02-07 16:12 dominikvitt Status new => assigned
2019-04-01 17:33 dominikvitt Status assigned => resolved
2019-04-01 17:33 dominikvitt Resolution open => fixed
2019-04-01 17:33 dominikvitt Fixed in Version => 3.16.x
2019-04-01 17:33 dominikvitt Note Added: 51252
2019-04-01 17:38 DenisChenu Note Added: 51254
2019-04-01 17:55 dominikvitt Note Added: 51258
2019-04-01 17:56 DenisChenu Note Added: 51259
2019-04-01 18:58 DenisChenu Note Added: 51262
2019-04-01 18:58 DenisChenu Note Edited: 51262 View Revisions
2019-04-02 16:41 ollehar Status resolved => closed
2019-04-02 16:41 ollehar Fixed in Version 3.16.x => 3.17.x