View Issue Details

IDProjectCategoryView StatusLast Update
14427Bug reports[All Projects] Survey designpublic2019-04-30 09:11
Reporterduvemyster Assigned ToDenisChenu  
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version3.15.x 
Target VersionFixed in Version3.15.x 
Summary14427: On an Active survey, Option 'Other' switched to Off when update question
Description

While a survey is Active survey,
on multiple choice questions with the Option 'Other' On,
if the number of display columns is changed,
then the Option 'Other' also turns Off.

Steps To Reproduce
  1. Activate a Active survey with a Multiple Choice question with Option 'Other' On and the number of columns set.
  2. Now change the # of display columns on this question while the survey is still active.
  3. Note that the Option 'Other' is now turned off.
Additional Information

This issue does not occur on a survey that is not active.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.15.6+190108
I will donate to the project if issue is resolvedNo
BrowserFirefox 64.0.2
Database & DB-Versionmysql driver version 5.5.60 on Mariadb
Server OS (if known)Linux Debian 3.16.56-1+deb8u1 x86_64
Webserver software & version (if known)Apache/2.4
PHP Version5.6.33-0+deb8u1

Relationships

has duplicate 14673 closedDenisChenu Saving set other='N' wrongly when editing a question on a active survey 

Activities

DenisChenu

DenisChenu

2019-01-15 08:54

developer   ~50193

Confirm an set to major since this settings must not be updatable when survey is activated

DenisChenu

DenisChenu

2019-01-15 09:27

developer   ~50196

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=28713

DenisChenu

DenisChenu

2019-01-15 09:42

developer   ~50204

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=28731

duvemyster

duvemyster

2019-01-15 15:26

reporter   ~50208

@DenisChenu, thank you for acting on this one so quickly!

DenisChenu

DenisChenu

2019-01-15 16:17

developer   ~50209

It's an easy fix :)

Related Changesets

LimeSurvey: master 3cb80451

2019-01-15 09:26:46

DenisChenu

Details Diff
Fixed issue 14427: On an Active survey, Option 'Other' switched to Off when update question
Dev: Disable update of Other when survey is activated
Dev: Review order of fixing, and don't fix always 1 to Y, and other to N (since it's a view issue here …)
Dev: remove usage of $_POST update
Affected Issues
14427
mod - application/controllers/admin/database.php Diff File

LimeSurvey: master b4caa56e

2019-01-15 09:41:50

DenisChenu

Details Diff
Dev: fixed issue 14427: Option 'Other' switched to Off , view part
Dev: just fix the view to be more clear
Affected Issues
14427
mod - application/views/admin/survey/Question/editQuestion_view.php Diff File

Issue History

Date Modified Username Field Change
2019-01-15 03:33 duvemyster New Issue
2019-01-15 08:54 DenisChenu Status new => confirmed
2019-01-15 08:54 DenisChenu Severity minor => major
2019-01-15 08:54 DenisChenu Note Added: 50193
2019-01-15 08:59 DenisChenu Assigned To => DenisChenu
2019-01-15 08:59 DenisChenu Status confirmed => assigned
2019-01-15 09:17 DenisChenu Summary On an Active survey, Option 'Other' On gets switched to Off if # of display columns is changed on a multiple choice question => On an Active survey, Option 'Other' On gets switched to Off when update question
2019-01-15 09:17 DenisChenu Summary On an Active survey, Option 'Other' On gets switched to Off when update question => On an Active survey, Option 'Other' switched to Off when update question
2019-01-15 09:27 DenisChenu Changeset attached => LimeSurvey master 3cb80451
2019-01-15 09:27 DenisChenu Note Added: 50196
2019-01-15 09:27 DenisChenu Resolution open => fixed
2019-01-15 09:28 DenisChenu Status assigned => resolved
2019-01-15 09:28 DenisChenu Fixed in Version => 3.15.x
2019-01-15 09:42 DenisChenu Changeset attached => LimeSurvey master b4caa56e
2019-01-15 09:42 DenisChenu Note Added: 50204
2019-01-15 15:26 duvemyster Note Added: 50208
2019-01-15 16:17 DenisChenu Note Added: 50209
2019-03-22 11:01 DenisChenu Relationship added has duplicate 14673
2019-04-30 09:11 c_schmitz Status resolved => closed