View Issue Details

This bug affects 1 person(s).
 4
IDProjectCategoryView StatusLast Update
14367Bug reportsSurvey editingpublic2021-09-09 09:00
Reportercharlottej990 Assigned Togalads  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.15.x 
Summary14367: IE11 Question Code crashes page if not unique
DescriptionEntering a duplicate Question Code in IE11 & pressing save, no longer results in the validation error message - the page crashes with a console error.
Steps To ReproduceScenario:

When creating a new question, you must give it a 'Code' and this must be unique. In previous versions on LimeSurvey, for IE11, you would get an error message if you enter a duplicate code which says 'Question codes must be unique. Required' and you cant proceed to save.

You still get this error message in Chrome/Edge/FireFox in the latest version of LimeSurvey (3.15.4+181109).

Expected:

In IE11, you should still get this validation error and not be able to save until you enter a unique code.

Actual:

There is no error message, you can save and then the page crashes with a console error of '$' not defined (see screenshot). If you press back in the browser, you then get the pop up validation errors regarding unique code being required (also screen-shotted).
TagsNo tags attached.
Bug heat4
Complete LimeSurvey version number (& build)3.15.4+181109
I will donate to the project if issue is resolvedNo
BrowserIE11
Database & DB-VersionmariaDB 10.1
Server OS (if known)
Webserver software & version (if known)
PHP Version7.2.12

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

charlottej990

charlottej990

2018-12-20 12:10

reporter  

dollarundefinedie11.png (72,284 bytes)   
dollarundefinedie11.png (72,284 bytes)   
ollehar

ollehar

2021-03-10 22:40

administrator   ~63205

Please update to the latest version and check if the bug can still be reproduced. Thank you.
galads

galads

2021-09-09 09:00

administrator   ~66422

Hello charlottej990,
I checked this with the latest version and could not reproduce, so this is most likely fixed for good.
Therefore, I am closing this issue. If you still can reproduce the issue using the latest version, please feel free to re-open the issue.
Thank you!

galads

Issue History

Date Modified Username Field Change
2018-12-20 12:10 charlottej990 New Issue
2018-12-20 12:10 charlottej990 File Added: questionnotcreatedie11.png
2018-12-20 12:10 charlottej990 File Added: dollarundefinedie11.png
2019-01-10 15:59 LouisGac Assigned To => markusfluer
2019-01-10 15:59 LouisGac Status new => assigned
2019-11-01 17:25 c_schmitz Category Survey design => Survey editing
2021-03-10 22:40 ollehar Assigned To markusfluer =>
2021-03-10 22:40 ollehar Status assigned => feedback
2021-03-10 22:40 ollehar Note Added: 63205
2021-09-09 09:00 galads Assigned To => galads
2021-09-09 09:00 galads Status feedback => closed
2021-09-09 09:00 galads Resolution open => fixed
2021-09-09 09:00 galads Note Added: 66422
2021-09-09 09:00 galads Bug heat 2 => 4