View Issue Details

IDProjectCategoryView StatusLast Update
14280Bug reports[All Projects] Print Viewpublic2018-12-04 17:09
ReporterMaziAssigned Todominikvitt 
PrioritynoneSeverityminor 
Status resolvedResolutionfixed 
Product Version3.15.x 
Target Version3.16.xFixed in Version3.15.x 
Summary14280: Print answers overview shows broken table format and missing details
Description

See attached screenshot:
a) When printing the details of an array question using the "print answers" feature, the table header is not placed properly. Instead of on top the answers are shown at the second row, after the first data set.
b) In addition, the dual scale questions are showing codes only:

  1. They are using "0" and "1" as fixed headers instead of using the "header scale" texts the users entered at the question settings.
  2. The subquestion texts are not listed, only the codes.
  3. We usually show answer text (and code) but in this case only the codes are shown
Steps To Reproduce

Import the attached test survey.
Activate it and enter some answers.
View the responses at the "Print answers" link at the end.

Additional Information

Tested using the default template

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.14.9+180917
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-VersionMySQL 5
Server OS (if known)Ubuntu 14 TLS
Webserver software & version (if known)Apache 2
PHP Version7.0.26

Relationships

parent of 14297 assigneddominikvitt Feature requests Missing setting to turn off showing answer/question codes at print answers overview 
Not all the children of this issue are yet resolved or closed.

Activities

Mazi

Mazi

2018-11-23 14:27

developer  

print_answers.png (45,550 bytes)
print_answers.png (45,550 bytes)
limesurvey_survey_353335_print_answers.lss (47,960 bytes)
dominikvitt

dominikvitt

2018-11-28 15:46

developer   ~49821

@Mazi:
is this how it should look like, according to your suggestions?



Mazi

Mazi

2018-11-28 16:25

developer   ~49822

@dominikvitt That looks very nice! Not sure if we should center headings and cell content? At the first multi-flexi question it looks a little misaligend because of the current left alignment.

And one more thing: Lots of users have asked for being able to switch off displaying the codes as well (they like having answers only). Is there a way to define a theme option for this?
Another approach would be a new global setting but I prefer the theme based approach since it is more flexible.

guest

guest

2018-11-28 16:52

viewer   ~49823

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=28571

dominikvitt

dominikvitt

2018-11-28 16:57

developer   ~49824

It is fixed.
Also, multi flexi array columns are centered.
@Mazi: please create a new Feature request for theme option for switching on/off of codes on print page

markusfluer

markusfluer

2018-12-04 17:09

manager   ~49883

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=28591

Related Changesets

LimeSurvey: master 114bc935

2018-11-28 16:50:55

Dominik Vitt

Details Diff
Fixed issue 14280: Print answers overview shows broken table format and missing details
mod - application/models/SurveyDynamic.php Diff File
mod - themes/survey/vanilla/views/subviews/printanswers/question_types/template_array-flexible-duel-scale.twig Diff File
mod - themes/survey/vanilla/views/subviews/printanswers/question_types/template_array-multi-flexi.twig Diff File

LimeSurvey: master 47abc047

2018-11-28 16:50:55

Dominik Vitt


Committer: markusfluer Details Diff
Fixed issue 14280: Print answers overview shows broken table format and missing details
mod - application/models/SurveyDynamic.php Diff File
mod - themes/survey/vanilla/views/subviews/printanswers/question_types/template_array-flexible-duel-scale.twig Diff File
mod - themes/survey/vanilla/views/subviews/printanswers/question_types/template_array-multi-flexi.twig Diff File

Issue History

Date Modified Username Field Change
2018-11-23 14:27 Mazi New Issue
2018-11-23 14:27 Mazi File Added: print_answers.png
2018-11-23 14:27 Mazi File Added: limesurvey_survey_353335_print_answers.lss
2018-11-28 10:52 dominikvitt Assigned To => dominikvitt
2018-11-28 10:52 dominikvitt Status new => assigned
2018-11-28 15:46 dominikvitt File Added: Screenshot_2018-11-28_15-44-05.png
2018-11-28 15:46 dominikvitt Note Added: 49821
2018-11-28 16:25 Mazi Note Added: 49822
2018-11-28 16:52 Changeset attached => LimeSurvey master 114bc935
2018-11-28 16:52 guest Note Added: 49823
2018-11-28 16:52 guest Resolution open => fixed
2018-11-28 16:57 dominikvitt Status assigned => resolved
2018-11-28 16:57 dominikvitt Fixed in Version => 3.15.x
2018-11-28 16:57 dominikvitt Note Added: 49824
2018-11-29 13:17 Mazi Relationship added parent of 14297
2018-12-04 17:09 markusfluer Changeset attached => LimeSurvey master 47abc047
2018-12-04 17:09 markusfluer Note Added: 49883