View Issue Details

IDProjectCategoryView StatusLast Update
14241Bug reports[All Projects] Survey takingpublic2019-05-15 13:41
ReporterDamianSAssigned Todominikvitt 
PrioritynoneSeverityminor 
Status closedResolutionunable to reproduce 
Product Version3.13.x 
Target VersionFixed in Version 
Summary14241: HTML Emails Not Using Expressions
Description

When customizing the email to use HTML to match our communication formatting only some of the expressions actually process correctly. Per the attached image the SURVEYNAME and ADMINNAME came across however the FIRSTNAME and SURVEYURL did not. When validating all fields are highlighted correctly.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.15.0+181008
I will donate to the project if issue is resolvedYes
BrowserChrome
Database & DB-VersionMySQL 5.0.12
Server OS (if known)Ubuntu 16.04
Webserver software & version (if known)Apache
PHP Version7.1.22

Activities

DamianS

DamianS

2018-11-12 16:57

reporter  

DenisChenu

DenisChenu

2018-11-13 12:10

developer   ~49625

For confirm only ? Or for invite and remind ?

DamianS

DamianS

2018-11-13 17:53

reporter   ~49632

I was trying to do invites and reminders.

DenisChenu

DenisChenu

2018-11-13 18:21

developer   ~49633

I personnaly can't reproduce : using last GIT version with html editor in popup or html editor online.

I think you have issue in your HTML source.

Maybe youcan check it with set HTML editor in popup mode in your preferences.

Maybe an issue with this HTML editor. (but if you want to make complex HTML : it's better to use HTML editor in popup mode).

Can you send a sample lss file ?

DamianS

DamianS

2018-11-13 18:24

reporter   ~49634

what is an lss file? (sorry i am new to limesurvey).

DamianS

DamianS

2018-11-13 18:25

reporter   ~49635

And yes, it is a complex html email designed to look perfect on all email clients...

DenisChenu

DenisChenu

2018-11-13 19:37

developer   ~49638

See it in Export : you have export type.

And i use too a lot of complex HTML structure and never have such issue.

dominikvitt

dominikvitt

2019-01-16 17:36

developer   ~50240

Browser extensions ( like HTTPS Everywhere, Simple Translate ) can mess up HTML code and placeholder substitution wouldn't work.

@DamianS Can you confirm if this issue is present when using browser with extensions disabled?

Issue History

Date Modified Username Field Change
2018-11-12 16:57 DamianS New Issue
2018-11-12 16:57 DamianS File Added: OUTLOOK_2018-11-12_10-47-51.png
2018-11-12 17:51 dominikvitt Assigned To => dominikvitt
2018-11-12 17:51 dominikvitt Status new => assigned
2018-11-13 12:10 DenisChenu Note Added: 49625
2018-11-13 17:53 DamianS Note Added: 49632
2018-11-13 18:21 DenisChenu Note Added: 49633
2018-11-13 18:24 DamianS Note Added: 49634
2018-11-13 18:25 DamianS Note Added: 49635
2018-11-13 19:37 DenisChenu Note Added: 49638
2019-01-16 17:36 dominikvitt Note Added: 50240
2019-05-15 13:41 dominikvitt Status assigned => closed
2019-05-15 13:41 dominikvitt Resolution open => unable to reproduce