View Issue Details

IDProjectCategoryView StatusLast Update
14142Bug reports[All Projects] Print Viewpublic2018-10-17 17:32
ReporterpotamoAssigned ToDenisChenu 
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.13.x 
Target VersionFixed in Version3.15.x 
Summary14142: Integer values in pdf report in multiple numerical input
Description

Integer values (settings 'only integer values') in multiple numerical input questions are shown as decimals in the pdf report.

Steps To Reproduce
  1. create multiple numerical input question
  2. settings 'only integer values' and 'customers can print answers'
  3. take survey
  4. print/download answers als pdf
Additional Information

Same issue with simple numerical input questions was resolved 14072.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.15.0+181008
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionMySQL 5
Operating System (Server)Linux
Webserver software & versionApache2
PHP VersionPHP 7.1

Activities

DenisChenu

DenisChenu

2018-10-14 18:54

developer   ~49319

Question value are shown at 2.000000 ? If yes : i think it must not be fixed only for integer …

2.00000 => 2
2.10000 => 2.1

:)

Best if you can send a lsa file :) (more quick to test)

potamo

potamo

2018-10-15 12:43

reporter   ~49323

Yes, question values (integer values) are shown with multiple decimal places, but only in multiple numeric input questions (screenshot). And yes, has to be fixed only for integer values.



DenisChenu

DenisChenu

2018-10-15 13:29

developer   ~49324

No,

I think it must be fixed in any condition : always remove the last 0 :)

DenisChenu

DenisChenu

2018-10-15 18:08

developer   ~49326

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=28329

potamo

potamo

2018-10-16 09:08

reporter   ~49332

Thank you a lot for fixing this.

Related Changesets

LimeSurvey: master c95a75c5

2018-10-15 18:08:08

DenisChenu

Details Diff
Fixed issue 14142: Integer values in pdf report in multiple numerical input
Dev: same fix than all at all other part … (qanda, export etc …)
Dev: think except with null : we don't have to test . since it's DECIMAL
mod - application/models/SurveyDynamic.php Diff File

Issue History

Date Modified Username Field Change
2018-10-11 09:49 potamo New Issue
2018-10-14 18:54 DenisChenu Note Added: 49319
2018-10-15 12:43 potamo File Added: limesurvey-integer-values.JPG
2018-10-15 12:43 potamo Note Added: 49323
2018-10-15 13:29 DenisChenu Note Added: 49324
2018-10-15 13:29 DenisChenu Assigned To => DenisChenu
2018-10-15 13:29 DenisChenu Status new => assigned
2018-10-15 18:08 DenisChenu Changeset attached => LimeSurvey master c95a75c5
2018-10-15 18:08 DenisChenu Note Added: 49326
2018-10-15 18:08 DenisChenu Resolution open => fixed
2018-10-15 19:10 DenisChenu Status assigned => resolved
2018-10-15 19:10 DenisChenu Fixed in Version => 3.15.x
2018-10-16 09:08 potamo Note Added: 49332
2018-10-17 17:32 dominikvitt Status resolved => closed