View Issue Details

IDProjectCategoryView StatusLast Update
14133Bug reports[All Projects] Import/Exportpublic2018-10-17 17:31
ReporterDenisChenu Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.14.x 
Target VersionFixed in Version3.15.x 
Summary14133: lss with long group name broke when import
Description

When importing a lss with more than 100 character for group_nale : broke when importing (and cut silently with debug=0)

Steps To Reproduce

set debug=2, try import : see error
set debug=0 : compare group name

Additional Information

lss updated manually, didn't test with TSV

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.14.11 github
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionmysql
Server OS (if known)debian
Webserver software & version (if known)apache2
PHP VersionPHP5.6

Activities

DenisChenu

DenisChenu

2018-10-06 11:17

developer  

limesurvey_survey_grouname.lss (13,679 bytes)
CDbException.html (26,406 bytes)
DenisChenu

DenisChenu

2018-10-06 11:26

developer   ~49272

Aaaargggg … fix is easy, but since launch a die … fix is lesser good than before …

We really need a better error control

DenisChenu

DenisChenu

2018-10-06 12:10

developer   ~49273

Dirty and quick fix : https://github.com/LimeSurvey/LimeSurvey/pull/1138
fix group_name silently

DenisChenu

DenisChenu

2018-10-15 14:23

developer   ~49325

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=28327

Related Changesets

LimeSurvey: master 01a7131c

2018-10-15 14:23:16

DenisChenu


Committer: GitHub Details Diff
Fixed issue 14133: lss with long group name broke when import (#1138)

Dev: since import_helper didn't have good error system … fix it silently
Affected Issues
14133
mod - application/helpers/admin/import_helper.php Diff File
mod - application/models/QuestionGroup.php Diff File

Issue History

Date Modified Username Field Change
2018-10-06 11:17 DenisChenu New Issue
2018-10-06 11:17 DenisChenu Status new => assigned
2018-10-06 11:17 DenisChenu Assigned To => DenisChenu
2018-10-06 11:17 DenisChenu File Added: limesurvey_survey_grouname.lss
2018-10-06 11:17 DenisChenu File Added: CDbException.html
2018-10-06 11:17 DenisChenu File Added: Capture du 2018-10-06 11-17-05.png
2018-10-06 11:17 DenisChenu Additional Information Updated View Revisions
2018-10-06 11:17 DenisChenu Additional Information Updated View Revisions
2018-10-06 11:26 DenisChenu Note Added: 49272
2018-10-06 11:27 DenisChenu Assigned To DenisChenu =>
2018-10-06 11:27 DenisChenu Status assigned => new
2018-10-06 12:10 DenisChenu Note Added: 49273
2018-10-15 14:23 DenisChenu Changeset attached => LimeSurvey master 01a7131c
2018-10-15 14:23 DenisChenu Note Added: 49325
2018-10-15 14:23 DenisChenu Assigned To => DenisChenu
2018-10-15 14:23 DenisChenu Resolution open => fixed
2018-10-15 17:46 DenisChenu Status new => resolved
2018-10-15 17:46 DenisChenu Fixed in Version => 3.15.x
2018-10-17 17:31 dominikvitt Status resolved => closed