View Issue Details

IDProjectCategoryView StatusLast Update
14130Feature requests[All Projects] Expression Managerpublic2018-11-03 16:03
ReporterjeloAssigned ToDenisChenu 
PrioritynoneSeverityfeature 
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Versiondevelop 
Summary14130: Allow to expose PHP functions to Expression Manager via config or GUI.
Description

Currently a few PHP functions are exposed to Expression manager.
The list could be longer. Perhaps a config.php entry to allow exposing via a generic system.

The em_core_helper.php could be a bit more open ;-)

TagsNo tags attached.

Relationships

duplicate of 13513 resolvedDenisChenu Update save way to add custom made EM functions 
related to 08522 new Upgrade EM number_format to accept $decimal 

Activities

DenisChenu

DenisChenu

2018-10-04 13:29

developer   ~49232

Or plugin event : remind we need 2 functions : one for PHP and one for JS. And sometimes php function can not be used like this …
If i remind there are already a feature request near this one

DenisChenu

DenisChenu

2018-10-06 10:38

developer   ~49269

https://github.com/LimeSurvey/LimeSurvey/pull/1081

Need review and one other dev «ok» : i put it for next dev team

DenisChenu

DenisChenu

2018-10-06 12:18

developer   ~49274

OK : see way to add a new ExpressionManager function here : https://github.com/LimeSurvey/LimeSurvey/pull/1081/files#diff-a05244074e414b80bca5b52851afaeb3R15
If merge request is accepted.

Maybe allow to use twig file here : https://github.com/LimeSurvey/LimeSurvey/pull/1081/files#diff-a05244074e414b80bca5b52851afaeb3R21

DenisChenu

DenisChenu

2018-10-16 17:24

developer   ~49342

@jelo : see plugin sample here : https://github.com/LimeSurvey/LimeSurvey/tree/develop/plugins/Demo/demoAddEmFunction

Issue History

Date Modified Username Field Change
2018-10-04 13:14 jelo New Issue
2018-10-04 13:29 DenisChenu Note Added: 49232
2018-10-06 10:38 DenisChenu Relationship added duplicate of 13513
2018-10-06 10:38 DenisChenu Note Added: 49269
2018-10-06 12:18 DenisChenu Note Added: 49274
2018-10-16 17:24 DenisChenu Assigned To => DenisChenu
2018-10-16 17:24 DenisChenu Status new => feedback
2018-10-16 17:24 DenisChenu Note Added: 49342
2018-10-17 09:58 DenisChenu Status feedback => resolved
2018-10-17 09:58 DenisChenu Resolution open => duplicate
2018-10-17 09:58 DenisChenu Fixed in Version => develop
2018-11-03 16:03 DenisChenu Relationship added related to 08522