View Issue Details

IDProjectCategoryView StatusLast Update
14112Bug reports[All Projects] Survey takingpublic2019-04-30 09:10
ReporterflolacAssigned Todominikvitt 
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version3.14.x 
Summary14112: list radio theme bootstrap
Description

I make a survey with questions listradio and theme "Bootstrap button".

All the question is compulsory. When I confirm my answers, If I did not answer a single question, the answers to the other question are not save. I again have to answer all the questions

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.14.8+180829
I will donate to the project if issue is resolvedNo
BrowserFirefox
Database & DB-VersionMysql
Server OS (if known)Apache
Webserver software & version (if known)Apache
PHP Versionphp 7

Activities

flolac

flolac

2018-09-28 16:26

reporter  

limesurvey_survey_952159(2).lss (19,396 bytes)
LouisGac

LouisGac

2018-09-28 16:58

manager   ~49187

when page reload because of a validation error, the selected answers in radio buttons are lost

DenisChenu

DenisChenu

2018-09-28 17:23

developer   ~49189

Last edited: 2018-09-28 17:29

View 2 revisions

Twig issue no ? Something with selected.

checkedState not fChecked …

Maybe core need to just send current value too

guest

guest

2018-10-01 14:52

viewer   ~49203

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=28190

Related Changesets

LimeSurvey: master f0275686

2018-10-01 14:45:22

Dominik Vitt

Details Diff
Fixed issue 14112: bootstrap theme list radio - answer value not preserved after validation error Affected Issues
14112
mod - themes/question/bootstrap_buttons/survey/questions/answer/listradio/rows/answer_row.twig Diff File

Issue History

Date Modified Username Field Change
2018-09-28 16:26 flolac New Issue
2018-09-28 16:26 flolac File Added: limesurvey_survey_952159(2).lss
2018-09-28 16:58 LouisGac Assigned To => LouisGac
2018-09-28 16:58 LouisGac Status new => confirmed
2018-09-28 16:58 LouisGac Note Added: 49187
2018-09-28 17:23 DenisChenu Note Added: 49189
2018-09-28 17:29 DenisChenu Note Edited: 49189 View Revisions
2018-10-01 11:12 LouisGac Assigned To LouisGac => dominikvitt
2018-10-01 14:52 Changeset attached => LimeSurvey master f0275686
2018-10-01 14:52 guest Note Added: 49203
2018-10-01 14:52 guest Resolution open => fixed
2018-10-01 14:56 dominikvitt Status confirmed => resolved
2018-10-01 14:56 dominikvitt Fixed in Version => 3.14.x
2019-04-30 09:10 c_schmitz Status resolved => closed