View Issue Details

IDProjectCategoryView StatusLast Update
13989Bug reports[All Projects] Translationpublic2019-04-17 18:09
Reporterprasan_3105Assigned Tocdorin 
PrioritynoneSeveritymajor 
Status closedResolutionunable to reproduce 
Product Version3.13.x 
Target VersionFixed in Version 
Summary13989: Russian characters are getting displayed as question marks
Description

I have created a survey and I have questions which should be displayed as Russian
but questions are displayed as question marks.
While creating questions the characters are displayed as Russian but after saving they are shown as Russian.
This is the case with 2.5 Version and Latest version.
Please help us to resolve this issue.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.14.5 Build 180815
I will donate to the project if issue is resolvedNo
Browserchrome
Database & DB-VersionSqlserver 2012 sp3
Server OS (if known)Linux
Webserver software & version (if known)Apache
PHP Version7.0.14

Relationships

related to 13904 closedc_schmitz Japanese characters get replaced with '?' 

Activities

prasan_3105

prasan_3105

2018-08-21 18:38

reporter  

Doc1.docx (512,479 bytes)
LouisGac

LouisGac

2018-08-22 12:10

manager   ~48845

Hi parsan, just select one the user browser fonts in the theme options.

LouisGac

LouisGac

2018-08-22 12:18

manager   ~48846

Last edited: 2018-08-22 12:19

View 2 revisions

also we'll update the roboto font to include Cyrillic alphabet.

jelo

jelo

2018-08-22 13:30

partner   ~48851

Bug 13904 might be about the same issue (Japanese characters into ???, MS SQL Server involved).

LouisGac

LouisGac

2018-08-22 14:33

manager   ~48852

I have to check for the japanese issue.

prasan_3105

prasan_3105

2018-08-22 15:14

reporter   ~48855

Thank you for the update. I have just tried by changing the theme option - to consider user font but it is still the same. The characters are getting converted to question marks
Yes this issue is similar to Bug 13904.
Please let me know once roboto font is updated or this issue is resolved.

jelo

jelo

2018-08-23 09:58

partner   ~48858

Can you check what admin theme is set? Configuration -> Themes -> Admin themes.

There is a admin theme
"Default LimeSurvey admin interface template with NOTO font. NOTO font is will provide a correct display for any existing language."

To me it looks more like an issue which LS only has when interacting with MS SQL.
But would be nice if you could try the NOTO theme with a few browsers and check if you sense a difference.

DenisChenu

DenisChenu

2018-12-18 00:23

developer   ~49979

One reason to don't use web fonts ;) for all text and by default

cdorin

cdorin

2019-03-08 17:05

manager   ~50862

Hey @prasan_3105, do you still have this issue?

cdorin

cdorin

2019-04-17 18:09

manager   ~51506

No feedback provided

Issue History

Date Modified Username Field Change
2018-08-21 18:38 prasan_3105 New Issue
2018-08-21 18:38 prasan_3105 File Added: Doc1.docx
2018-08-22 12:10 LouisGac Note Added: 48845
2018-08-22 12:18 LouisGac Note Added: 48846
2018-08-22 12:19 LouisGac Note Edited: 48846 View Revisions
2018-08-22 13:29 jelo Relationship added related to 13904
2018-08-22 13:30 jelo Note Added: 48851
2018-08-22 14:33 LouisGac Note Added: 48852
2018-08-22 15:14 prasan_3105 Note Added: 48855
2018-08-23 09:58 jelo Note Added: 48858
2018-12-18 00:23 DenisChenu Note Added: 49979
2019-03-08 17:05 cdorin Status new => feedback
2019-03-08 17:05 cdorin Description Updated View Revisions
2019-03-08 17:05 cdorin Note Added: 50862
2019-04-17 18:09 cdorin Assigned To => cdorin
2019-04-17 18:09 cdorin Status feedback => closed
2019-04-17 18:09 cdorin Resolution open => unable to reproduce
2019-04-17 18:09 cdorin Note Added: 51506