View Issue Details

IDProjectCategoryView StatusLast Update
13911Bug reports[All Projects] Survey takingpublic2018-08-07 17:01
ReporterDenisChenuAssigned Tomarkusfluer 
PrioritylowSeverityminor 
Status closedResolutionfixed 
Product Version3.13.x 
Target VersionFixed in Version3.13.x 
Summary13911: Multi submit action done
Description

At end of survey if you click multiple times on Submit button : restart survey.

Steps To Reproduce

Import included survey, lauch make more than one click on submit (i clic/clic/clic)
With a plugin who do a lot of think before end page : it's more clear (try with https://gitlab.com/SondagesPro/ExportAndStats/pdfReport (doc have lss + picture)).

Additional Information

There are only one survey saved , but maybe with all in one page : we can have multiple response

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.13.2 github
I will donate to the project if issue is resolvedNo
Browserff
Database & DB-Versionmariadb
Server OS (if known)debian
Webserver software & version (if known)apache2
PHP VersionPHP5.6

Activities

DenisChenu

DenisChenu

2018-07-25 20:04

developer  

limesurvey_survey_simplest.lss (13,084 bytes)
DenisChenu

DenisChenu

2018-07-26 12:37

developer   ~48577

https://github.com/LimeSurvey/LimeSurvey/pull/1101/commits/5f84d759c9f54501e09ecee6525ecb65a14b6959

LouisGac

LouisGac

2018-07-30 17:49

manager   ~48619

I can't reproduce

DenisChenu

DenisChenu

2018-07-31 10:45

developer  

limesurvey_survey_367929-forcedAjax.lss (13,077 bytes)
Screencast_31-07-2018_10:43:30.webm (520,634 bytes)
DenisChenu

DenisChenu

2018-07-31 10:45

developer   ~48631

Need ajax mode on

DenisChenu

DenisChenu

2018-07-31 10:46

developer   ~48632

Last edited: 2018-07-31 16:38

View 2 revisions

Sreencast send : 2 first time : multiclick : restart the survey.
3rd time : one click : see the endpage

LouisGac

LouisGac

2018-07-31 10:56

manager   ~48633

thank you

markusfluer

markusfluer

2018-08-06 16:47

administrator   ~48660

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=27747

markusfluer

markusfluer

2018-08-07 17:01

administrator   ~48690

Release 3.14.2+180807

Related Changesets

LimeSurvey: master 5a6a9ba2

2018-08-06 16:46:59

markusfluer

Details Diff
Fixed issue 13911: Multi submit action done Affected Issues
13911
mod - themes/survey/vanilla/scripts/ajaxify.js Diff File

Issue History

Date Modified Username Field Change
2018-07-25 20:04 DenisChenu New Issue
2018-07-25 20:04 DenisChenu File Added: limesurvey_survey_simplest.lss
2018-07-26 12:37 DenisChenu Note Added: 48577
2018-07-30 17:49 LouisGac Note Added: 48619
2018-07-31 10:45 DenisChenu File Added: limesurvey_survey_367929-forcedAjax.lss
2018-07-31 10:45 DenisChenu File Added: Screencast_31-07-2018_10:43:30.webm
2018-07-31 10:45 DenisChenu Note Added: 48631
2018-07-31 10:46 DenisChenu Note Added: 48632
2018-07-31 10:56 LouisGac Note Added: 48633
2018-07-31 11:59 LouisGac Assigned To => markusfluer
2018-07-31 11:59 LouisGac Status new => assigned
2018-07-31 11:59 LouisGac Priority none => low
2018-07-31 16:38 DenisChenu Note Edited: 48632 View Revisions
2018-08-06 16:47 markusfluer Changeset attached => LimeSurvey master 5a6a9ba2
2018-08-06 16:47 markusfluer Note Added: 48660
2018-08-06 16:47 markusfluer Resolution open => fixed
2018-08-06 16:47 markusfluer Status assigned => resolved
2018-08-06 16:47 markusfluer Fixed in Version => 3.13.x
2018-08-07 17:01 markusfluer Status resolved => closed
2018-08-07 17:01 markusfluer Note Added: 48690