View Issue Details

IDProjectCategoryView StatusLast Update
13895Bug reports[All Projects] RemoteControlpublic2018-09-17 10:00
ReporterJulesGAssigned Todominikvitt 
PrioritynoneSeverityminor 
Status resolvedResolutionunable to reproduce 
Product Version3.13.x 
Target VersionFixed in Version 
Summary13895: remote control ‘set_survey_properties’ method issue - "Calling parameters do not match signature"
Description

Hello,
I want to update my limeSurvey 2.06 to 3.13.2 but,
When calling ‘set_survey_properties’ method via xmlrpc in a PHP program, an error is raised :
Fault code: 623
Fault string: Calling parameters do not match signature

I had the same issue when I used 'add_participants' method when I used an associative Array on the parameters '$aParticipantData' but when I use a simple array the issue gone. Unfortunately this solution can't be used for 'set_survey_properties' method
I read the new manual : https://manual.limesurvey.org/RemoteControl_2_API but i don’t saw any solution

Steps To Reproduce

Here the code:
(the survey is already created with id pass on $survey variable)

$webServiceUrl = $this->container->getParameter('webServiceUrl');
$limesurvey_login = $this->container->getParameter('limesurvey_login');
$limesurvey_password = $this->container->getParameter('limesurvey_password');
$client = new Client($webServiceUrl);
$sessionKey = $client->call('get_session_key', array($limesurvey_login, $limesurvey_password));
$newSurveyId = intval($survey);
$dataBegin = "2013-01-01 00:00:00";
$dataEnd = "2013-01-01 00:00:00";
$aSurveyData = array('startdate' => $dataBegin, 'expires' => $dataEnd);
client->call('set_survey_properties', array($sessionKey, $newSurveyId, $aSurveyData));

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.13.2+180709
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-Versionmysql
Operating System (Server)Windows 7
Webserver software & versionApache/2.4.33
PHP Version7.2.5

Activities

LouisGac

LouisGac

2018-08-07 10:21

manager   ~48665

dominik: could you investigate this one?

JulesG

JulesG

2018-08-20 14:27

reporter   ~48827

Hello,
thank you for the assignment of my problem.

JulesG

JulesG

2018-09-12 17:03

reporter   ~49021

Hello,
Do you have any answers?

dominikvitt

dominikvitt

2018-09-14 17:25

developer   ~49047

It works as expected, unable to reproduce on the latest LimeSurvey version.
I used this code, only last 2 lines are shown:
$aSurveyData = array('startdate' => '2013-01-01 00:00:00', 'expires' => '2013-01-01 00:00:00');
$response = $myJSONRPCClient->set_survey_properties($sessionKey, $survey_id, $aSurveyData);

Data array works okay, maybe there is a problem with $sessionKey or $survey_id?

JulesG

JulesG

2018-09-17 10:00

reporter   ~49058

Hello,
Thank you for your reply.
You seemed to use a JSON-RPC Client to use the API, but originally my application was using the XML-RPC.
I have since changed to JSON-RPC and actually all seems to work.
Thank you for your research.
Cordially

Issue History

Date Modified Username Field Change
2018-07-23 16:20 JulesG New Issue
2018-08-07 10:21 LouisGac Assigned To => dominikvitt
2018-08-07 10:21 LouisGac Status new => assigned
2018-08-07 10:21 LouisGac Note Added: 48665
2018-08-20 14:27 JulesG Note Added: 48827
2018-09-12 17:03 JulesG Note Added: 49021
2018-09-14 17:25 dominikvitt Status assigned => resolved
2018-09-14 17:25 dominikvitt Resolution open => unable to reproduce
2018-09-14 17:25 dominikvitt Note Added: 49047
2018-09-17 10:00 JulesG Note Added: 49058