View Issue Details

IDProjectCategoryView StatusLast Update
13890Bug reports[All Projects] Survey takingpublic2018-08-09 13:43
ReportergeraldpaleAssigned ToLouisGac 
PrioritynoneSeverityminor 
Status assignedResolutionreopened 
Product Version3.13.x 
Target VersionFixed in Version 
Summary13890: Representation of 5 point choice question with slider layout "star"
DescriptionQuestion:
5 point choice question with slider layout "star"

Behaviour:
1) User fills out the 5 point choice question
2) User skips a mandatory question
3) User wants to finish the survey. However, a reminder is shown that a mandatory question is not filled out.
4) If the input for the 5 point choice question with slider layout "star" is between 0-4 everything works fine. However, if the input is 5 the user input isn't represented. Thus, it looks like the user input is lost and the question has to be re-answered.

Setup:
New Limesuvey instance used from limesurvey.org. Link to example survey: https://testtesttt.limequery.com/377191?lang=en
Same behaviour on our productive server (Specification entered below)
TagsNo tags attached.
Complete LimeSurvey version number (& build)3.13.2
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionMySQL 5.6.19-67.0-log
Operating System (Server)Linux
Webserver software & versionApache/2.4.29
PHP Version7.1.10

Activities

geraldpale

geraldpale

2018-07-20 17:30

reporter  

limesurvey_survey_377191.lss (14,954 bytes)
LouisGac

LouisGac

2018-07-30 18:04

manager   ~48621

I can't reproduce the bug.
geraldpale

geraldpale

2018-08-07 10:57

reporter   ~48669

Thank you for the feedback. I'll tried various server with plain limesurvey installations with the same output.

1) Please visit: https://testtesttt.limequery.com/377191?lang=en
2) Answer Question 1 "FivePointChoice1 - Mandator" with 5 stars
3) Submit the survey
4) Note "One or more mandatory questions have not been answered. You cannot proceed until these have been completed." occurs
5) Indication of question 1 (5 stars) is gone

geraldpale

geraldpale

2018-08-07 11:00

reporter  

1-2-3.PNG (30,384 bytes)
1-2-3.PNG (30,384 bytes)
4.PNG (41,711 bytes)
4.PNG (41,711 bytes)
5.PNG (29,783 bytes)
5.PNG (29,783 bytes)
LouisGac

LouisGac

2018-08-08 10:57

manager   ~48752

can you confirm you're running the latest version? what build are you using?
geraldpale

geraldpale

2018-08-09 13:35

reporter   ~48766

The sample survey (https://testtesttt.limequery.com/377191?lang=en) is running on Version 3.14.2. However, I can't see the build because this is only available on "LimeSurvey Professional" (???)

I did a installation on a test environment (LimeSurvey version 3.13.2; LimeSurvey build 180709) and I'm able to reproduce the behaviour.
geraldpale

geraldpale

2018-08-09 13:43

reporter   ~48767

I updated the installation in the test environment to LimeSurvey version 3.14.2 / LimeSurvey build 180807.
Still the same behaviour.

Issue History

Date Modified Username Field Change
2018-07-20 17:30 geraldpale New Issue
2018-07-20 17:30 geraldpale File Added: limesurvey_survey_377191.lss
2018-07-30 18:04 LouisGac Assigned To => LouisGac
2018-07-30 18:04 LouisGac Status new => resolved
2018-07-30 18:04 LouisGac Resolution open => unable to reproduce
2018-07-30 18:04 LouisGac Note Added: 48621
2018-08-07 10:57 geraldpale Status resolved => feedback
2018-08-07 10:57 geraldpale Resolution unable to reproduce => reopened
2018-08-07 10:57 geraldpale Note Added: 48669
2018-08-07 11:00 geraldpale File Added: 1-2-3.PNG
2018-08-07 11:00 geraldpale File Added: 4.PNG
2018-08-07 11:00 geraldpale File Added: 5.PNG
2018-08-08 10:57 LouisGac Note Added: 48752
2018-08-09 13:35 geraldpale Note Added: 48766
2018-08-09 13:35 geraldpale Status feedback => assigned
2018-08-09 13:43 geraldpale Note Added: 48767