View Issue Details

IDProjectCategoryView StatusLast Update
13859Bug reports[All Projects] Survey takingpublic2019-01-30 12:10
ReporterDenisChenu Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.13.x 
Target VersionFixed in Version3.15.x 
Summary13859: Question full index loose color when try submit
Description

When trying to submit , question index loose all color of an error happen.

Steps To Reproduce

Import included survey + template (template is here for a quickest way to view the issue)
Move to last group
See the error/warning css part in index : good
Try to submit
Back to 2st group (good) but all color are removed.

Additional Information

Since it was totally fixed in 3.0_answerhtml …
And i think color are here in 2.X version …

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.13.2
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Activities

DenisChenu

DenisChenu

2018-07-10 11:10

developer  

indextop_fruity.zip (135,480 bytes)
limesurvey_survey_SampleFullIndex.lss (362,061 bytes)
DenisChenu

DenisChenu

2018-12-03 09:27

developer   ~49860

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=28580

DenisChenu

DenisChenu

2019-01-25 13:05

developer   ~50310

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=28802

DenisChenu

DenisChenu

2019-01-25 13:06

developer   ~50311

Reopen since was reverted …

DenisChenu

DenisChenu

2019-01-25 13:36

developer   ~50312

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=28803

Related Changesets

LimeSurvey: master 44356dc6

2018-12-03 09:27:43

DenisChenu


Committer: GitHub Details Diff
Fixed issue 13859: Question full index loose color when try submit

Dev : pull request #1187
Dev: disable usage of StartSurvey: it reset indexGseq/indexQseq and we don't want
Dev: moving to step 0 (1st with question)
Dev: tested with hidden 1st group (by relevance or hidden question) and 1st question (but not really used)
Affected Issues
13859
mod - application/helpers/SurveyRuntimeHelper.php Diff File
mod - application/helpers/expressions/em_manager_helper.php Diff File

LimeSurvey: master 86b256d0

2019-01-25 12:59:57

DenisChenu

Details Diff
Revert "Fixed issue 13859: Question full index loose color when try submit"

This reverts commit 44356dc68b748d361b0a91669ebe6f4100ab8928.
Affected Issues
13859, 14451
mod - application/helpers/SurveyRuntimeHelper.php Diff File
mod - application/helpers/expressions/em_manager_helper.php Diff File

LimeSurvey: master 57974fa2

2019-01-25 13:35:50

DenisChenu

Details Diff
Fixed issue 13859: Question full index loose color when try submit
Dev: save current page before go to step 0
Affected Issues
13859
mod - application/helpers/SurveyRuntimeHelper.php Diff File

Issue History

Date Modified Username Field Change
2018-07-10 11:10 DenisChenu New Issue
2018-07-10 11:10 DenisChenu File Added: Capture du 2018-07-10 11-06-02.png
2018-07-10 11:10 DenisChenu File Added: Capture du 2018-07-10 11-06-32.png
2018-07-10 11:10 DenisChenu File Added: Capture du 2018-07-10 11-06-50.png
2018-07-10 11:10 DenisChenu File Added: indextop_fruity.zip
2018-07-10 11:10 DenisChenu File Added: limesurvey_survey_SampleFullIndex.lss
2018-11-28 09:54 DenisChenu Assigned To => DenisChenu
2018-11-28 09:54 DenisChenu Status new => assigned
2018-12-03 09:27 DenisChenu Changeset attached => LimeSurvey master 44356dc6
2018-12-03 09:27 DenisChenu Note Added: 49860
2018-12-03 09:27 DenisChenu Resolution open => fixed
2018-12-03 09:28 DenisChenu Status assigned => resolved
2018-12-03 09:28 DenisChenu Fixed in Version => 3.15.x
2019-01-25 13:05 DenisChenu Changeset attached => LimeSurvey master 86b256d0
2019-01-25 13:05 DenisChenu Note Added: 50310
2019-01-25 13:05 DenisChenu Status resolved => confirmed
2019-01-25 13:06 DenisChenu Note Added: 50311
2019-01-25 13:36 DenisChenu Changeset attached => LimeSurvey master 57974fa2
2019-01-25 13:36 DenisChenu Note Added: 50312
2019-01-25 13:36 DenisChenu Status confirmed => resolved
2019-01-30 12:10 ollehar Status resolved => closed