View Issue Details

IDProjectCategoryView StatusLast Update
13831Bug reports[All Projects] Import/Exportpublic2018-08-07 17:01
ReporterAmadeus14Assigned Tomarkusfluer 
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.13.x 
Target VersionFixed in Version3.13.x 
Summary13831: Export of survey-structure (*.lss - Files) is not possible in LS 3.13.0
Description

after selecting the survey-structure-export - menu it is possible to select any export format and create export file.
Just if you select the first item "survey structure (*.lss)", nothing happens after clicking the item and then the export-button.
Export of survey is not possible in LS 3.13.0.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.13.0
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Version?
Operating System (Server)all
Webserver software & version?
PHP Version?

Activities

Amadeus14

Amadeus14

2018-06-30 09:03

reporter  

LS - Fehler Export Lss - Screenshot1.jpg (162,572 bytes)
Amadeus14

Amadeus14

2018-07-02 09:25

reporter   ~48426

Affected System: LimeSurvey 3.13.1 !!!

olle

olle

2018-07-02 10:40

administrator   ~48428

Which browser are you using? Did you try with Firefox?

Amadeus14

Amadeus14

2018-07-02 11:19

reporter   ~48430

Yes, Firefox - newest release (64-bit).

Amadeus14

Amadeus14

2018-07-02 11:27

reporter   ~48432

... additional information:
I tried it with Firefox using OSX, Windows 10, Windows 7 and LInuxMint.
And I tried it with our hosted Server-Installation (provider: DomainFactory) and with local installations.



FFBrowserVersion.jpg (113,133 bytes)
LouisGac

LouisGac

2018-07-02 11:34

manager   ~48433

we can't reproduce here.
can you try to clean your asset cache?
(in configuration -> global settings -> General -> Clear Now)

olle

olle

2018-07-02 14:35

administrator   ~48436

Language dependent. Dominik will fix it.

Amadeus14

Amadeus14

2018-07-02 15:22

reporter   ~48438

ok.
I cleaned my asset cache - but no effect.
Thanks for your last note! Do you need a short videoclip, that shows the problem or is this not necessary because you did detect the problem?

LouisGac

LouisGac

2018-07-02 15:23

manager   ~48439

no it's ok. It's about to be fixed.
we'll let you know when your installation will be updated.

olle

olle

2018-07-03 10:47

administrator   ~48441

Is this resolved?

dominikvitt

dominikvitt

2018-07-03 10:51

developer   ~48442

Not yet, only hotfix was applied to Lime Service.

markusfluer

markusfluer

2018-07-04 14:15

manager   ~48448

Since the data is written into a json document, double quotes will always destroy execution.
Only way to provide this is to apply a new filter for the gT that replaces double quotes by single quotes.

olle

olle

2018-07-04 14:25

administrator   ~48449

Doesn't the 'js' gT filter work?

markusfluer

markusfluer

2018-07-04 14:32

manager   ~48450

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=27585

markusfluer

markusfluer

2018-08-07 17:01

manager   ~48722

Release 3.14.2+180807

Related Changesets

LimeSurvey: master 7e9e5e00

2018-07-04 14:32:25

markusfluer

Details Diff
Fixed issue 13831: Export of survey-structure (*.lss - Files) is not possible in LS 3.13.0
mod - application/extensions/admin/PreviewModalWidget/PreviewModalWidget.php Diff File
mod - application/extensions/admin/PreviewModalWidget/views/grouped_select_modal.php Diff File
mod - application/extensions/admin/PreviewModalWidget/views/open_modal_button.php Diff File
mod - application/helpers/common_helper.php Diff File
mod - application/views/admin/survey/surveybar_displayexport.php Diff File

Issue History

Date Modified Username Field Change
2018-06-30 09:03 Amadeus14 New Issue
2018-06-30 09:03 Amadeus14 File Added: LS - Fehler Export Lss - Screenshot1.jpg
2018-07-02 09:25 Amadeus14 Note Added: 48426
2018-07-02 09:51 olle Assigned To => markusfluer
2018-07-02 09:51 olle Status new => assigned
2018-07-02 10:40 olle Note Added: 48428
2018-07-02 11:19 Amadeus14 Note Added: 48430
2018-07-02 11:27 Amadeus14 File Added: FFBrowserVersion.jpg
2018-07-02 11:27 Amadeus14 Note Added: 48432
2018-07-02 11:34 LouisGac Note Added: 48433
2018-07-02 14:35 olle Assigned To markusfluer => dominikvitt
2018-07-02 14:35 olle Note Added: 48436
2018-07-02 15:22 Amadeus14 Note Added: 48438
2018-07-02 15:23 LouisGac Note Added: 48439
2018-07-02 15:45 dominikvitt Assigned To dominikvitt => markusfluer
2018-07-03 10:47 olle Note Added: 48441
2018-07-03 10:51 dominikvitt Note Added: 48442
2018-07-04 14:15 markusfluer Note Added: 48448
2018-07-04 14:25 olle Note Added: 48449
2018-07-04 14:32 markusfluer Changeset attached => LimeSurvey master 7e9e5e00
2018-07-04 14:32 markusfluer Note Added: 48450
2018-07-04 14:32 markusfluer Resolution open => fixed
2018-07-04 14:32 markusfluer Status assigned => resolved
2018-07-04 14:32 markusfluer Fixed in Version => 3.13.x
2018-08-07 17:01 markusfluer Status resolved => closed
2018-08-07 17:01 markusfluer Note Added: 48722