View Issue Details

IDProjectCategoryView StatusLast Update
13803Bug reports[All Projects] Ergonomypublic2018-08-07 17:01
ReporterDenisChenu Assigned Tomarkusfluer  
PrioritynoneSeverityminor 
Status closedResolutionreopened 
Product Version3.12.x 
Target VersionFixed in Version3.13.x 
Summary13803: Deprecated confirm box since 3.0 alpha
Description

In anser html : there are the project to show a beautifull boc for 'clear cancel /ok'
It's disapeare before 3.0 beta release

Steps To Reproduce

Click on Clear your answers : default javascript confirm

Additional Information

3.0 pre-alpha version : https://testing.sondages.pro/answershtml/index.php/69285?lang=fr
Not in core but in default template

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.12.1 github
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Activities

DenisChenu

DenisChenu

2018-06-21 18:50

developer  

markusfluer

markusfluer

2018-06-27 14:21

administrator   ~48316

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=27551

c_schmitz

c_schmitz

2018-06-28 16:58

administrator   ~48374

Version 3.13.0 released

DenisChenu

DenisChenu

2018-07-25 16:22

developer   ~48571

This broke API version for user template …

markusfluer

markusfluer

2018-08-07 17:01

administrator   ~48685

Release 3.14.2+180807

Related Changesets

LimeSurvey: master 32ceb099

2018-06-27 14:20:38

markusfluer

Details Diff
Fixed issue 13803: Deprecated confirm box since 3.0 alpha Affected Issues
13803
mod - application/config/third_party.php Diff File
mod - application/extensions/LimeScript/LimeScript.php Diff File
mod - application/helpers/SurveyRuntimeHelper.php Diff File
mod - application/views/admin/survey/Question/_subQuestionsAndAnwsersJsVariables.php Diff File
add - assets/packages/bootstrap/plugins/bootstrapconfirm/README.md Diff File
add - assets/packages/bootstrap/plugins/bootstrapconfirm/bootstrapconfirm.js Diff File
add - assets/packages/bootstrap/plugins/bootstrapconfirm/bootstrapconfirm.min.js Diff File
add - assets/packages/bootstrap/plugins/bootstrapconfirm/bootstrapconfirm.src.js Diff File
add - assets/packages/bootstrap/plugins/bootstrapconfirm/compile.sh Diff File
add - assets/packages/bootstrap/plugins/bootstrapconfirm/package.json Diff File
mod - assets/packages/limesurvey/survey.js Diff File

Issue History

Date Modified Username Field Change
2018-06-21 18:50 DenisChenu New Issue
2018-06-21 18:50 DenisChenu File Added: Capture du 2018-06-21 18-46-27.png
2018-06-21 18:50 DenisChenu File Added: Capture du 2018-06-21 18-49-03.png
2018-06-25 10:22 LouisGac Assigned To => markusfluer
2018-06-25 10:22 LouisGac Status new => assigned
2018-06-27 14:20 markusfluer Status assigned => resolved
2018-06-27 14:20 markusfluer Resolution open => fixed
2018-06-27 14:20 markusfluer Fixed in Version => 3.12.x
2018-06-27 14:21 markusfluer Changeset attached => LimeSurvey master 32ceb099
2018-06-27 14:21 markusfluer Note Added: 48316
2018-06-28 16:58 c_schmitz Note Added: 48374
2018-06-28 16:58 c_schmitz Status resolved => closed
2018-07-25 16:22 DenisChenu Status closed => feedback
2018-07-25 16:22 DenisChenu Resolution fixed => reopened
2018-07-25 16:22 DenisChenu Note Added: 48571
2018-08-06 16:51 markusfluer Status feedback => resolved
2018-08-06 16:51 markusfluer Fixed in Version 3.12.x => 3.13.x
2018-08-07 17:01 markusfluer Status resolved => closed
2018-08-07 17:01 markusfluer Note Added: 48685