View Issue Details

IDProjectCategoryView StatusLast Update
13542Bug reports[All Projects] Survey takingpublic2018-05-25 11:30
ReporterDenisChenu Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version3.6.x 
Summary13542: Question index (head) show diable even if work
Description

Whan activate Question index in Question by question mode : show "Disable", but it work in incremental mode

Steps To Reproduce

Import included survey, test

Additional Information

See https://github.com/Shnoulle/LimeSurvey-Shnoulle/blob/b027cc9e90acf58242994638b1b8722ec291255b/themes/survey/vanilla/views/subviews/navigation/question_index_questions_buttons.twig

For working part in button (navigator) part

Maybe we can show a warning to user ONLY if he able to update Survey settings

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.5.4 github
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Relationships

related to 13544 closedDenisChenu Unable to use flatEllipsizeText function in (some) twig file 

Activities

DenisChenu

DenisChenu

2018-03-27 15:37

developer  

limesurvey_survey_indexQuestion.lss (570,136 bytes)
DenisChenu

DenisChenu

2018-03-30 15:41

developer   ~47300

https://github.com/LimeSurvey/LimeSurvey/pull/1032

DenisChenu

DenisChenu

2018-04-11 17:41

developer   ~47406

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=26982

c_schmitz

c_schmitz

2018-05-25 11:30

administrator   ~47845

Version 3.8.1+180524 released

Related Changesets

LimeSurvey: master b3991a41

2018-04-11 17:41:31

DenisChenu

Details Diff
Fixed issue 13542: Question index (head) show diable even if work
Dev: incremental mode work since start
Dev: full work as incremental , put a informative string
Dev: Use ellipsizeString in button index
Affected Issues
13542
mod - themes/survey/vanilla/config.xml Diff File
add - themes/survey/vanilla/css/base.css Diff File
mod - themes/survey/vanilla/views/subviews/navigation/question_index_menu.twig Diff File
mod - themes/survey/vanilla/views/subviews/navigation/question_index_questions_buttons.twig Diff File

Issue History

Date Modified Username Field Change
2018-03-27 15:37 DenisChenu New Issue
2018-03-27 15:37 DenisChenu Status new => assigned
2018-03-27 15:37 DenisChenu Assigned To => LouisGac
2018-03-27 15:37 DenisChenu File Added: limesurvey_survey_indexQuestion.lss
2018-03-27 15:37 DenisChenu File Added: Capture du 2018-03-27 15-33-10.png
2018-03-30 14:53 DenisChenu Relationship added related to 13544
2018-03-30 14:53 DenisChenu Assigned To LouisGac => DenisChenu
2018-03-30 15:41 DenisChenu Status assigned => feedback
2018-03-30 15:41 DenisChenu Note Added: 47300
2018-03-30 15:42 DenisChenu Assigned To DenisChenu => LouisGac
2018-04-10 18:40 DenisChenu Assigned To LouisGac => DenisChenu
2018-04-10 18:40 DenisChenu Status feedback => assigned
2018-04-11 17:41 DenisChenu Changeset attached => LimeSurvey master b3991a41
2018-04-11 17:41 DenisChenu Note Added: 47406
2018-04-11 17:41 DenisChenu Resolution open => fixed
2018-04-11 18:38 DenisChenu Status assigned => resolved
2018-04-11 18:38 DenisChenu Fixed in Version => 3.6.x
2018-05-25 11:30 c_schmitz Note Added: 47845
2018-05-25 11:30 c_schmitz Status resolved => closed