View Issue Details

IDProjectCategoryView StatusLast Update
13502Bug reports[All Projects] Survey designpublic2018-05-30 16:55
ReporterDenisChenuAssigned ToLouisGac 
PriorityhighSeverityminor 
Status closedResolutionunable to reproduce 
Product Version3.5.x 
Target VersionFixed in Version 
Summary13502: debug=2 : unable to show survey list
Description

See PHP Notice

Steps To Reproduce

?
I think i have a false survey (survey but no langage maybe).

Additional Information

Can't send DB
User doing lss (xml) using excel macro (don't ask me …)

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.5.3 180316
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionmysql
Operating System (Server)Linux 4.14.19-ovh-vps-grsec-zfs-classid
Webserver software & versionApache
PHP Version7.0.27

Activities

DenisChenu

DenisChenu

2018-03-19 19:42

developer  

PHP notice.html (47,557 bytes)
DenisChenu

DenisChenu

2018-03-19 19:51

developer   ~47132

PS : it's not this->template, comment it break with the line before

markusfluer

markusfluer

2018-03-20 15:10

manager   ~47137

it's the owner->users_name
No legal owner to a survey

DenisChenu

DenisChenu

2018-03-20 15:44

developer   ~47139

Yes ? And we must fix in any situation no ?
legal owner + langage broken + template broken
No ?

If one is invalid : didn't broke survey listing

DenisChenu

DenisChenu

2018-03-20 15:46

developer   ~47140

Maybe : add a default empty owner when loading Survey ? owner->uid=0;owner->login="";owner->username=""
?

Issue History

Date Modified Username Field Change
2018-03-19 19:42 DenisChenu New Issue
2018-03-19 19:42 DenisChenu File Added: PHP notice.html
2018-03-19 19:51 DenisChenu Note Added: 47132
2018-03-20 15:10 markusfluer Note Added: 47137
2018-03-20 15:15 markusfluer Assigned To => markusfluer
2018-03-20 15:15 markusfluer Status new => feedback
2018-03-20 15:44 DenisChenu Note Added: 47139
2018-03-20 15:44 DenisChenu Status feedback => assigned
2018-03-20 15:46 DenisChenu Note Added: 47140
2018-05-16 13:46 LouisGac Assigned To markusfluer => LouisGac
2018-05-23 12:58 LouisGac Priority none => high
2018-05-30 16:55 LouisGac Status assigned => closed
2018-05-30 16:55 LouisGac Resolution open => unable to reproduce