View Issue Details

IDProjectCategoryView StatusLast Update
13494Bug reports[All Projects] Survey takingpublic2018-03-21 18:47
ReporterDenisChenu Assigned Tomarkusfluer  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.5.x 
Target VersionFixed in Version3.5.x 
Summary13494: Problem when activating force_xmlsettings_for_survey_rendering
Description

No way to rank item (javascript enable) when force_xmlsettings_for_survey_rendering is true

Steps To Reproduce

set force_xmlsettings_for_survey_rendering = true in config_defaults
then import included survey , test. tested too with bootsrap template

Additional Information

Tested too with ranking_advanced (see screenshot)

Problem is that the TemplateManifest is ignoring the packages to add parameter

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.5.3 github
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Activities

DenisChenu

DenisChenu

2018-03-16 19:40

developer  

limesurvey_survey_rankingBroken.lss (14,080 bytes)
DenisChenu

DenisChenu

2018-03-16 19:54

developer   ~47103

Can not test before https://github.com/LimeSurvey/LimeSurvey/commit/2547051b79fe41572b6cf3d5bf19ee61b7138f16#diff-c90402604812a00287877cafb2e02fda

Because at this commit id : jquery seems not loaded … and admin GUI didn't have way to edit question …

But it work good at https://github.com/LimeSurvey/LimeSurvey/commit/cfbe5975314dc031f63025f2e75f3df20d3aa4b5

DenisChenu

DenisChenu

2018-03-17 00:03

developer   ~47105

ajaxify issue

Removing ajaxify.js fix the issue (hava another issue but after).
PS set ajax to NO didn't remove ajaxify call



markusfluer

markusfluer

2018-03-19 10:26

administrator   ~47107

I can't reproduce this.
You are sure you haven't changed anything?

DenisChenu

DenisChenu

2018-03-19 10:28

developer   ~47109

Yes, git reset + git pull.

c_schmitz

c_schmitz

2018-03-19 10:46

administrator   ~47110

Can't reproduce it either.
Can you reproduce using the demo?

ollehar

ollehar

2018-03-19 10:46

administrator   ~47111

No problem for me on a fresh install. Denis, can you try that too? Maybe it's something in your config that enables ajax mode?

DenisChenu

DenisChenu

2018-03-19 10:48

developer   ~47112

$ cd LimeSurvey_master/
$ git reset --hard
HEAD is now at cd6e000 Updated translation: Polish by elissa
$ git pull
Already up-to-date.
$ touch assets/packages/pjax/.ok
$ rm assets/packages/pjax/.ok

DenisChenu

DenisChenu

2018-03-19 10:49

developer  

limesurvey_survey_479923.lss (16,520 bytes)
DenisChenu

DenisChenu

2018-03-19 10:52

developer   ~47113

Last edited: 2018-03-19 10:55

View 2 revisions

OK on demo
https://master.sondages.pro/479923?newtest=Y&lang=en

javascript link :
<link rel="stylesheet" type="text/css" href="/assets/styles-public/lime-progress.css" />
<script type='text/javascript'>window.debugState = {frontend : (0 === 1), backend : (0 === 1)};</script><script type="text/javascript" src="/third_party/jquery/jquery-3.1.1.js" class="headScriptTag"></script>
<script type="text/javascript" src="/third_party/jquery/jquery-migrate-3.0.0.js" class="headScriptTag"></script>
<script type="text/javascript" src="/assets/packages/limesurvey/survey.js" class="headScriptTag"></script>
<script type="text/javascript" src="/assets/packages/template-core/template-core.js" class="headScriptTag"></script>
<script type="text/javascript" src="/assets/packages/bootstrap/bootstrap.js" class="headScriptTag"></script>
<script type="text/javascript" src="/themes/survey/vanilla/scripts/theme.js" class="headScriptTag"></script>
<script type="text/javascript" src="/themes/survey/vanilla/scripts/ajaxify.js" class="headScriptTag"></script>
<script type="text/javascript" src="/themes/survey/vanilla/scripts/custom.js" class="headScriptTag"></script>
<script type="text/javascript" src="/assets/scripts/survey_runtime.js" class="headScriptTag"></script>
<script type="text/javascript" src="/assets/scripts/admin/expression.js" class="headScriptTag"></script>
<script type="text/javascript" src="/assets/scripts/expressions/em_javascript.js" class="headScriptTag"></script>
<script type="text/javascript" src="/assets/scripts/nojs.js" class="headScriptTag"></script>
<script type="text/javascript">
/<![CDATA[/
LSvar={"bFixNumAuto":1,"bNumRealValue":0,"sLEMradix":".","lang":{},"showpopup":1,"startPopups":{},"debugMode":2};
/]]>/
</script>

debug at 2 AND 'force_xmlsettings_for_survey_rendering' => true,

markusfluer

markusfluer

2018-03-19 10:54

administrator   ~47114

Why are you deleting pjax? of course it won't work without it...

DenisChenu

DenisChenu

2018-03-19 10:56

developer   ~47115

Last edited: 2018-03-19 10:56

View 2 revisions

I create a file in directory + delete it after : I DON'T DELETE PJAX, please have a real look

To be sure to have last asset version

DenisChenu

DenisChenu

2018-03-19 10:57

developer   ~47116

Last edited: 2018-03-19 10:58

View 3 revisions

'force_xmlsettings_for_survey_rendering' => true, => false

Fix the issue for default, but not for “extended”

ollehar

ollehar

2018-03-19 10:58

administrator   ~47117

OBS: Using force_xmlsettings_for_survey_rendering also enables ajax mode (if ajax mode = on in config, which is the default value).

DenisChenu

DenisChenu

2018-03-19 11:43

developer   ~47118

Last edited: 2018-03-19 11:44

View 2 revisions

Arg, didn't know that : thanks

But issue really strange :

  • Set to true since some week : broke ranking
  • Set to false : fix ranking
  • Set to true : ranking (default) seem fixed …
markusfluer

markusfluer

2018-03-19 18:26

administrator   ~47130

Updated bug report to reflect the real problem

markusfluer

markusfluer

2018-03-19 18:26

administrator   ~47131

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&amp;id=26804

DenisChenu

DenisChenu

2018-03-20 07:36

developer   ~47133

Markus : something i don't understand : why with DB it work ? You hav 2 different system for add/remove ? one for DB and one for install ?

markusfluer

markusfluer

2018-03-20 12:12

administrator   ~47134

Yes and now. Yes, the xml gets loaded via the Model TemplateManifest and the Database gets loaded via TemplateConfiguration.
The basis of both of them is TemplateConfig, which has most of the shared methods, but some are a bit different and thus seperated into the two systems.

The xml-based system just did not have the packages_to_load functionality implemented.

c_schmitz

c_schmitz

2018-03-21 18:47

administrator   ~47165

Release 3.5.4+180320

Related Changesets

LimeSurvey: master 0c973e19

2018-03-19 18:26:20

markusfluer

Details Diff
Fixed issue 13494: Problem when activating force_xmlsettings_for_survey_rendering Affected Issues
13494
mod - application/config/packages.php Diff File
mod - application/models/TemplateManifest.php Diff File

Issue History

Date Modified Username Field Change
2018-03-16 19:40 DenisChenu New Issue
2018-03-16 19:40 DenisChenu File Added: Capture du 2018-03-16 19-36-36.png
2018-03-16 19:40 DenisChenu File Added: limesurvey_survey_rankingBroken.lss
2018-03-16 19:54 DenisChenu Note Added: 47103
2018-03-16 19:55 DenisChenu Summary Ranking (default) question type broken => Ranking question type broken
2018-03-16 19:57 DenisChenu Assigned To => markusfluer
2018-03-16 19:57 DenisChenu Status new => assigned
2018-03-17 00:01 DenisChenu Summary Ranking question type broken => Javascript question type broken
2018-03-17 00:03 DenisChenu File Added: Capture du 2018-03-17 00-02-34.png
2018-03-17 00:03 DenisChenu Note Added: 47105
2018-03-19 10:26 markusfluer Note Added: 47107
2018-03-19 10:28 DenisChenu Note Added: 47109
2018-03-19 10:46 c_schmitz Note Added: 47110
2018-03-19 10:46 ollehar Note Added: 47111
2018-03-19 10:48 DenisChenu Note Added: 47112
2018-03-19 10:49 DenisChenu File Added: limesurvey_survey_479923.lss
2018-03-19 10:52 DenisChenu Note Added: 47113
2018-03-19 10:54 markusfluer Note Added: 47114
2018-03-19 10:55 DenisChenu Note Edited: 47113 View Revisions
2018-03-19 10:56 DenisChenu Note Added: 47115
2018-03-19 10:56 DenisChenu Note Edited: 47115 View Revisions
2018-03-19 10:57 DenisChenu Note Added: 47116
2018-03-19 10:57 DenisChenu Note Edited: 47116 View Revisions
2018-03-19 10:58 DenisChenu Note Edited: 47116 View Revisions
2018-03-19 10:58 ollehar Note Added: 47117
2018-03-19 11:43 DenisChenu Note Added: 47118
2018-03-19 11:44 DenisChenu Note Edited: 47118 View Revisions
2018-03-19 18:26 markusfluer Summary Javascript question type broken => Problem when activating force_xmlsettings_for_survey_rendering
2018-03-19 18:26 markusfluer Description Updated View Revisions
2018-03-19 18:26 markusfluer Steps to Reproduce Updated View Revisions
2018-03-19 18:26 markusfluer Additional Information Updated View Revisions
2018-03-19 18:26 markusfluer Note Added: 47130
2018-03-19 18:26 markusfluer Changeset attached => LimeSurvey master 0c973e19
2018-03-19 18:26 markusfluer Note Added: 47131
2018-03-19 18:26 markusfluer Resolution open => fixed
2018-03-20 07:36 DenisChenu Note Added: 47133
2018-03-20 12:12 markusfluer Note Added: 47134
2018-03-20 12:12 markusfluer Status assigned => resolved
2018-03-20 12:12 markusfluer Fixed in Version => 3.5.x
2018-03-21 18:47 c_schmitz Status resolved => closed
2018-03-21 18:47 c_schmitz Note Added: 47165