View Issue Details

IDProjectCategoryView StatusLast Update
13484Bug reports[All Projects] Survey designpublic2018-04-30 22:42
Reportercairomckenzie Assigned Tomarkusfluer  
PrioritynoneSeverityminor 
Status assignedResolutionopen 
Product Version3.3.x 
Target VersionFixed in Version 
Summary13484: After adding question, error messages appear
Description

After adding a question to a group, a popup error message appears on the page informing user that:

"Question could not be created with error on title: Question codes must be unique"

and

"Question could not be created"

The question, however, appears to be created, in spite of these warnings.

Steps To Reproduce
  1. Within a survey design group, click on 'Add question' in the left tab
  2. create a unique question code
  3. click on 'Save and new' in top right corner
  4. Error page will appear.
TagsNo tags attached.
Complete LimeSurvey version number (& build)3.5.3+ 180316
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-Versionmariadb
Server OS (if known)ubuntu 16.04
Webserver software & version (if known)apache 2
PHP Version7

Activities

cairomckenzie

cairomckenzie

2018-03-15 14:59

reporter  

errorpic.PNG (30,562 bytes)
errorpic.PNG (30,562 bytes)
jboogie21

jboogie21

2018-03-15 15:37

reporter   ~47079

It seems like the above error only occurs when clicking "Save and new." Clicking the "save" button doesn't cause the same error.

c_schmitz

c_schmitz

2018-03-15 16:02

administrator   ~47080

I cannot reproduce this issue.

jelo

jelo

2018-03-15 16:57

partner   ~47081

What version of LimeSurvey is used?
Really Version 3.5.3+180316?
There is a comfortupdate message in your screenshot, which offers a new update? Wonder what that could be.

I cannot reproduce the issue with Firefox and Chrome under Windows.
Chrome build used is 65.0.3325.146.

c_schmitz

c_schmitz

2018-03-15 17:13

administrator   ~47084

@jelo Olle seems to be able to reproduce it on Linux ( I am Windows too, maybe that's the reason).

cairomckenzie

cairomckenzie

2018-03-15 17:49

reporter   ~47091

Just ran another test. Took a screenshot with version labeled at the bottom right.



2nd error pic.PNG (74,460 bytes)
2nd error pic.PNG (74,460 bytes)
JamesHarrisHKI

JamesHarrisHKI

2018-04-30 22:42

reporter   ~47558

I'm seeing the same problem on LimeSurvey 3.7.1+180424. We're running Apache 2.4.23 on Windows Server 2008.

The original reporter says that the question is created in spite of the warnings, but for me the question is not being created. The error occurs across multiple surveys, users, browsers, and computers.

If I click "Save" I get a blank white screen and I get the errors when I click "Back". If I click "Save and new" I just get the error screen.

Issue History

Date Modified Username Field Change
2018-03-15 14:59 cairomckenzie New Issue
2018-03-15 14:59 cairomckenzie File Added: errorpic.PNG
2018-03-15 15:37 jboogie21 Note Added: 47079
2018-03-15 16:02 c_schmitz Note Added: 47080
2018-03-15 16:57 jelo Note Added: 47081
2018-03-15 17:12 c_schmitz Assigned To => markusfluer
2018-03-15 17:12 c_schmitz Status new => assigned
2018-03-15 17:13 c_schmitz Note Added: 47084
2018-03-15 17:49 cairomckenzie File Added: 2nd error pic.PNG
2018-03-15 17:49 cairomckenzie Note Added: 47091
2018-04-30 22:42 JamesHarrisHKI Note Added: 47558