View Issue Details

IDProjectCategoryView StatusLast Update
13470Bug reports[All Projects] Otherpublic2018-03-14 18:33
ReportertpartnerAssigned Tomarkusfluer 
PrioritynoneSeverityminor 
Status assignedResolutionreopened 
Product Version3.5.x 
Target Version3.5.xFixed in Version3.5.x 
Summary13470: Files in /upload/ directory not ignored by GIT
Description

After recent changes to .gitignore, none of the files in /upload/ directory are ignored as they should be.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.5.1
I will donate to the project if issue is resolvedNo
BrowserN/A
Database & DB-Versionmysqlnd 5.0.12-dev
Operating System (Server)Windows 10
Webserver software & versionApache/2.4.27 (Win32) OpenSSL/1.0.2l PHP/7.1.9
PHP Version7.1.9

Activities

tpartner

tpartner

2018-03-12 19:16

developer  

capture-2.png (107,957 bytes)
olle

olle

2018-03-13 12:29

administrator   ~47030

Same for me.

tpartner

tpartner

2018-03-14 17:40

developer   ~47047

I do not see this as fixed after a fresh GIT pull today.

tpartner

tpartner

2018-03-14 18:03

developer   ~47051

...GIT version: 2.16.2.windows.1

tpartner

tpartner

2018-03-14 18:33

developer   ~47054

I think the problem is the change in .gitignore to the . wildcard combinations.

I don't see the star-dot-star combination anywhere here - https://git-scm.com/docs/gitignore.

Changing those combinations back to a single asterisk seems to cure the issue.

Additionally, why is the ignoring of everything in /upload/admintheme/ negated at line 22 of that file? Shouldn't everything in that folder except index.html be ignored?

Issue History

Date Modified Username Field Change
2018-03-12 19:16 tpartner New Issue
2018-03-12 19:16 tpartner Status new => assigned
2018-03-12 19:16 tpartner Assigned To => markusfluer
2018-03-12 19:16 tpartner File Added: capture-2.png
2018-03-13 12:29 olle Note Added: 47030
2018-03-14 17:21 markusfluer Status assigned => resolved
2018-03-14 17:21 markusfluer Resolution open => fixed
2018-03-14 17:21 markusfluer Fixed in Version => 3.5.x
2018-03-14 17:40 tpartner Note Added: 47047
2018-03-14 17:41 tpartner Status resolved => feedback
2018-03-14 17:41 tpartner Resolution fixed => reopened
2018-03-14 18:03 tpartner Note Added: 47051
2018-03-14 18:03 tpartner Status feedback => assigned
2018-03-14 18:33 tpartner Note Added: 47054