View Issue Details

IDProjectCategoryView StatusLast Update
13465Bug reports[All Projects] Survey designpublic2018-03-13 16:10
ReporterDenisChenuAssigned Tomarkusfluer 
PrioritynoneSeverityminor 
Status closedResolutionreopened 
Product Version3.4.x 
Target VersionFixed in Version 
Summary13465: PHP Notice when view survey
Description

PHP Notice when view survey (debug=2)

Steps To Reproduce

Update to the last version (git) set debug at 2

Additional Information

Unlog, log (to reset session) didn't fix the issue

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.5.0 git 461d672
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Operating System (Server)not relevant
Webserver software & versionnot relevant
PHP Versionnot relevant

Activities

DenisChenu

DenisChenu

2018-03-09 15:47

developer  

PHP notice.html (38,530 bytes)
DenisChenu

DenisChenu

2018-03-09 15:51

developer   ~46974

Update version : didn't see it was released https://github.com/LimeSurvey/LimeSurvey/commit/461d6725f015898828b217c0bcbf28af61ea7374

olle

olle

2018-03-09 15:56

administrator   ~46975

This is due to a change in db updater. Making a clean install will fix it. This problem only happens for people who git pull, not releases.

DenisChenu

DenisChenu

2018-03-09 17:29

developer   ~46993

It's really the solution ? New install ?
Why you don't give the Db update link , seems a minimum …

olle

olle

2018-03-12 10:07

administrator   ~47005

Yeah, well... If you just modify the dbupdate instead of adding a new dbupdate that corrects the previous, faulty dbupdate, then you have to do a fresh install or manually revert the database version. That's what Markus chose to do. I guess he assumed no one outside the core team regularly make "git pull".

tpartner

tpartner

2018-03-13 14:43

developer   ~47031

What do I need to do to fix this. To be honest, a new install is not an option if you want people to contribute to testing.

olle

olle

2018-03-13 14:48

administrator   ~47032

ping @markusfluer

markusfluer

markusfluer

2018-03-13 15:16

manager   ~47033

Reset database version to 347 in settings_global.
The updatedbhelper will create the correct fields

olle

olle

2018-03-13 16:10

administrator   ~47034

Closing this again, if everyone is happy.

Issue History

Date Modified Username Field Change
2018-03-09 15:47 DenisChenu New Issue
2018-03-09 15:47 DenisChenu File Added: PHP notice.html
2018-03-09 15:49 DenisChenu Additional Information Updated View Revisions
2018-03-09 15:51 DenisChenu Additional Information Updated View Revisions
2018-03-09 15:51 DenisChenu Complete LimeSurvey version number (& build) 3.4.4 git 461d672 => 3.5.0 git 461d672
2018-03-09 15:51 DenisChenu Note Added: 46974
2018-03-09 15:51 DenisChenu Assigned To => markusfluer
2018-03-09 15:51 DenisChenu Status new => assigned
2018-03-09 15:56 olle Note Added: 46975
2018-03-09 15:56 olle Status assigned => closed
2018-03-09 15:56 olle Resolution open => fixed
2018-03-09 17:29 DenisChenu Note Added: 46993
2018-03-12 10:07 olle Note Added: 47005
2018-03-13 14:43 tpartner Note Added: 47031
2018-03-13 14:48 olle Note Added: 47032
2018-03-13 14:49 olle Status closed => new
2018-03-13 14:49 olle Resolution fixed => reopened
2018-03-13 15:16 markusfluer Note Added: 47033
2018-03-13 16:10 olle Status new => closed
2018-03-13 16:10 olle Note Added: 47034