View Issue Details

IDProjectCategoryView StatusLast Update
13445Bug reports[All Projects] Import/Exportpublic2018-03-09 16:36
Reporteribl Assigned Toc_schmitz  
PrioritynoneSeveritycrash 
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version3.4.x 
Summary13445: Out of Bound
Description

Interner Serverfehler
CDbCommand konnte das SQL-Statement nicht ausführen: SQLSTATE[HY093]: Invalid parameter number: number of bound variables does not match number of tokens

Beim Bearbeiten Ihrer Anfrage durch den Webserver ist ein interner Fehler aufgetreten. Bitte kontaktieren Sie the webmaster um dieses Problem zu melden.

Vielen Dank.

Steps To Reproduce

Wenn man die Antworten eine Umfrage exportieren möchte (Simple (359138) Ergebnisse exportieren) kommt bei jeder Umfrage, auch wenn diese ganz einfach ist und nur aus einer Ja/Nein-Frage besteht der o.g. Fehler. Die sonstigen Exporteinstellungen scheinen auch egal zu sein (habe mehrere ausprobiert), die gewählten siehe Bild im Anhang.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.4.3+180227
I will donate to the project if issue is resolvedNo
Browseregal (Firefox 58.0.2 (64-Bit))
Database & DB-Version5.5.50-0+deb8u1
Server OS (if known)Debian jessie
Webserver software & version (if known)2.4.10-10+deb8u5
PHP Version5.6.24+dfsg-0+deb8u1

Relationships

has duplicate 13430 closedc_schmitz Exit of statistics 

Activities

ibl

ibl

2018-03-04 18:58

reporter  

snapshot01.png (70,972 bytes)
snapshot01.png (70,972 bytes)
ibl

ibl

2018-03-04 19:05

reporter   ~46878

Translation:
Trying to export the answers of a survey results in an error-message, even with a very simple survey, only y/n-question.
I tried different formats (CSV, PDF etc.).

orvil

orvil

2018-03-04 20:01

reporter  

Clipboard31.jpg (63,222 bytes)
Clipboard31.jpg (63,222 bytes)
orvil

orvil

2018-03-04 20:01

reporter   ~46885

Unfortunately I cannot reproduce this in my 3.4.3 installation. Are you sure its 3.4.3?
My export view looks different:

ibl

ibl

2018-03-05 09:28

reporter   ~46889

Yes, I am shure ;-) but here are two ways to export the answers. One way is your screenshot and, indeed, that works for me, too (thank you for the hint). The second way, that results in the error, is selecting some answers and then exporting only the selected answers.

orvil

orvil

2018-03-05 18:58

reporter   ~46913

Thanks for this detail (second way, did not know this) => now I got the same error

c_schmitz

c_schmitz

2018-03-09 13:25

administrator   ~46964

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=26701

c_schmitz

c_schmitz

2018-03-09 16:36

administrator   ~46980

Version 3.5.0 180309 released

Related Changesets

LimeSurvey: master 952b1eb8

2018-03-09 13:25:27

c_schmitz

Details Diff
Fixed issue 13445: Out of Bound error when exporting marked responses from response list Affected Issues
13445
mod - application/helpers/admin/export/SurveyDao.php Diff File

Issue History

Date Modified Username Field Change
2018-03-04 18:58 ibl New Issue
2018-03-04 18:58 ibl File Added: snapshot01.png
2018-03-04 19:05 ibl Note Added: 46878
2018-03-04 20:01 orvil File Added: Clipboard31.jpg
2018-03-04 20:01 orvil Note Added: 46885
2018-03-05 09:28 ibl Note Added: 46889
2018-03-05 18:58 orvil Note Added: 46913
2018-03-09 13:17 c_schmitz Relationship added has duplicate 13430
2018-03-09 13:25 c_schmitz Changeset attached => LimeSurvey master 952b1eb8
2018-03-09 13:25 c_schmitz Note Added: 46964
2018-03-09 13:25 c_schmitz Assigned To => c_schmitz
2018-03-09 13:25 c_schmitz Resolution open => fixed
2018-03-09 13:25 c_schmitz Status new => resolved
2018-03-09 13:25 c_schmitz Fixed in Version => 3.4.x
2018-03-09 16:36 c_schmitz Note Added: 46980
2018-03-09 16:36 c_schmitz Status resolved => closed