View Issue Details

IDProjectCategoryView StatusLast Update
13419Bug reports[All Projects] Survey designpublic2018-03-09 16:36
Reporterjosep Assigned Tomarkusfluer  
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version3.4.x 
Target VersionFixed in Version3.4.x 
Summary13419: Re-ordering questions and groups using Structure drag & drop fails
Description

When you re-orders questions of a question group or groups using drag & drop facilities, items are assigned (more or less) in random order.

Steps To Reproduce

Create a survey.
Create at least 3 questions.
Change order of questions.
Execute survey or verify exeuting SQL "select qid, title, gid, question_order from lime_questions where ..."

TagsNo tags attached.
Complete LimeSurvey version number (& build) 3.4.2 LimeSurvey build 180223
I will donate to the project if issue is resolvedNo
BrowserFirefox / Chromium
Database & DB-Versionpostgresql-9.6 9.6.6-0+deb9u1
Server OS (if known)GNU Linux Debian 9.3
Webserver software & version (if known)apache2 2.4.25-3+deb9u3
PHP Versionphp7.0 7.0.27-0+deb9u1

Activities

ollehar

ollehar

2018-02-26 15:41

administrator   ~46755

Cannot reproduce. More info?

josep

josep

2018-02-27 10:14

reporter   ~46765

Hi,

I upload a survey and 4 screenshots.

test01a.png and test-01b.png shows initial position of questions at screen and database

I move 4th question [RepresentantNIF] to top of question group and I get

test-02a.png and test02-b.png.

As you can see, the rows of the table of the database do not correspond with the order wished of the questions.

Thank's in advance.



limesurvey_survey_999.lss (292,318 bytes)
test-01a.png (32,229 bytes)
test-01a.png (32,229 bytes)
test-01b.png (13,520 bytes)
test-01b.png (13,520 bytes)
test-02a.png (12,354 bytes)
test-02a.png (12,354 bytes)
test-02b.png (11,963 bytes)
test-02b.png (11,963 bytes)
ollehar

ollehar

2018-02-27 10:38

administrator   ~46766

Ah, you use the question tree, and not the old organizer: index.php/admin/survey/sa/organize/surveyid/999

Still, I can't reproduce. Can you enable debug => 2 in config.php? Also check the browser debug console, F12, for possible JavaScript errors, or if the network/server returns 500.

ollehar

ollehar

2018-02-27 10:39

administrator   ~46767

Also, which page are you on when doing the rearrangement? Can you give me the full URL?

ollehar

ollehar

2018-02-27 10:39

administrator   ~46768

Tried with both MySQL and Postgres.

josep

josep

2018-02-27 11:44

reporter   ~46777

Perhaps will be a good idea include and menu entry to access to old organizer as a workaround.

I check JS console, but I have no errors.

I set debug=2. Where the log file is?

ollehar

ollehar

2018-02-27 12:03

administrator   ~46779

The old organizer is accessible if you collapse the side-menu.

ollehar

ollehar

2018-02-27 12:05

administrator   ~46780

Last edited: 2018-02-27 12:15

View 2 revisions

When debug is set to 2, you can check the network tab in the browser dev tool (F12). The new order is saved using an Ajax call to the server. You should be able to see if that call returns any errors. Is this too technical to follow, or do you think you can do it?

josep

josep

2018-02-28 10:36

reporter   ~46813

I modify ./application/config/config.php as is:

'config'=>array(
// debug: Set this to 1 if you are looking for errors. If you still get no errors after enabling this
// then please check your error-logs - either in your hosting provider admin panel or in some /logs directory
// on your webspace.
// LimeSurvey developers: Set this to 2 to additionally display STRICT PHP error messages and get full access to standard templates
'debug'=>2,
'debugsql'=>0, // Set this to 1 to enanble sql logging, only active when debug = 2
// Update default LimeSurvey config here
)

It's rigth?

I check the network ('Xarxa' in catalan) tab in the browser dev tool (F12). I move questions and I get first screenshot and JS tab shows second screenshot.



ollehar

ollehar

2018-02-28 10:46

administrator   ~46816

Well, this all looks good. And you can still reproduce the issue?

josep

josep

2018-02-28 11:51

reporter   ~46818

Yes, I can.

ollehar

ollehar

2018-02-28 12:02

administrator   ~46822

@markusfluer, can you reproduce this issue? I couldn't.

josep

josep

2018-03-01 10:47

reporter   ~46847

Because exists a workaround, I think severity can be lower than major.

Thank's for you work.

markusfluer

markusfluer

2018-03-05 18:18

administrator   ~46908

Reproduced it!
I will fix it.

markusfluer

markusfluer

2018-03-05 18:29

administrator   ~46909

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=26665

josep

josep

2018-03-06 08:32

reporter   ~46915

Thank you very much!

c_schmitz

c_schmitz

2018-03-09 16:36

administrator   ~46990

Version 3.5.0 180309 released

Related Changesets

LimeSurvey: master 0d75f9f5

2018-03-05 18:29:09

markusfluer

Details Diff
Fixed issue 13419: Re-ordering questions and groups using Structure drag & drop fails Affected Issues
13419
mod - application/controllers/admin/questiongroups.php Diff File
mod - application/views/admin/super/sidemenu.php Diff File
mod - assets/packages/adminpanel/build/lsadminpanel.debug.js Diff File
mod - assets/packages/adminpanel/build/lsadminpanel.js Diff File
mod - assets/packages/adminpanel/build/lsadminpanel.min.js Diff File
mod - assets/packages/adminpanel/src/components/sidebar.vue Diff File

Issue History

Date Modified Username Field Change
2018-02-26 14:42 josep New Issue
2018-02-26 15:41 ollehar Assigned To => ollehar
2018-02-26 15:41 ollehar Status new => feedback
2018-02-26 15:41 ollehar Note Added: 46755
2018-02-27 10:14 josep File Added: limesurvey_survey_999.lss
2018-02-27 10:14 josep File Added: test-01a.png
2018-02-27 10:14 josep File Added: test-01b.png
2018-02-27 10:14 josep File Added: test-02a.png
2018-02-27 10:14 josep File Added: test-02b.png
2018-02-27 10:14 josep Note Added: 46765
2018-02-27 10:14 josep Status feedback => assigned
2018-02-27 10:38 ollehar Note Added: 46766
2018-02-27 10:39 ollehar Note Added: 46767
2018-02-27 10:39 ollehar Status assigned => feedback
2018-02-27 10:39 ollehar Note Added: 46768
2018-02-27 10:39 ollehar Product Version 3.1.x => 3.4.x
2018-02-27 11:44 josep Note Added: 46777
2018-02-27 11:44 josep Status feedback => assigned
2018-02-27 12:03 ollehar Note Added: 46779
2018-02-27 12:05 ollehar Note Added: 46780
2018-02-27 12:15 ollehar Note Edited: 46780 View Revisions
2018-02-27 12:15 ollehar Status assigned => feedback
2018-02-28 10:36 josep File Added: Screenshot_20180228_103222.png
2018-02-28 10:36 josep File Added: Screenshot_20180228_103536.png
2018-02-28 10:36 josep Note Added: 46813
2018-02-28 10:36 josep Status feedback => assigned
2018-02-28 10:46 ollehar Note Added: 46816
2018-02-28 11:51 josep Note Added: 46818
2018-02-28 12:02 ollehar Assigned To ollehar => markusfluer
2018-02-28 12:02 ollehar Note Added: 46822
2018-03-01 10:47 josep Note Added: 46847
2018-03-05 18:18 markusfluer Note Added: 46908
2018-03-05 18:29 markusfluer Changeset attached => LimeSurvey master 0d75f9f5
2018-03-05 18:29 markusfluer Note Added: 46909
2018-03-05 18:29 markusfluer Resolution open => fixed
2018-03-05 18:29 markusfluer Status assigned => resolved
2018-03-05 18:29 markusfluer Fixed in Version => 3.4.x
2018-03-06 08:32 josep Note Added: 46915
2018-03-09 16:36 c_schmitz Note Added: 46990
2018-03-09 16:36 c_schmitz Status resolved => closed