View Issue Details

IDProjectCategoryView StatusLast Update
13396Bug reports[All Projects] Theme editorpublic2018-03-05 17:31
Reportertpartner Assigned Toollehar  
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version3.4.x 
Target VersionFixed in Version3.4.x 
Summary13396: Some files/folders not included in imported survey themes
Description

When importing a theme via the theme editor, some files and folders are missed.

For example, when importing the attached theme:

  • the file jquery.maskedinput.js is missed with an "Skipped" message - attached screenshot capture-5.png
  • the /options and /views directories are missed without any "Skipped" message, resulting in a PHP error - attached screenshot capture-6.png
Steps To Reproduce

Using theme editor, import the attached theme.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.4.0
I will donate to the project if issue is resolvedNo
BrowserN/A
Database & DB-Versionmysqlnd 5.0.12-dev
Server OS (if known)Windows 10
Webserver software & version (if known)Apache/2.4.27 (Win32) OpenSSL/1.0.2l PHP/7.1.9
PHP Version7.1.9

Activities

tpartner

tpartner

2018-02-21 16:00

developer  

capture-6.png (32,290 bytes)
capture-6.png (32,290 bytes)
capture-5.png (36,414 bytes)
capture-5.png (36,414 bytes)
extends_bootswatch_mask_test.zip (161,401 bytes)
ollehar

ollehar

2018-03-02 13:40

administrator   ~46866

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=26632

ollehar

ollehar

2018-03-02 13:46

administrator   ~46867

You JS file is skipped because it has two dots in the file name. So the uploader thinks it's has two file extensions. It's the same issue in 2.73.

tpartner

tpartner

2018-03-02 14:01

developer   ~46870

As far as I know, that is a valid filename format, so should not be skipped - https://en.wikipedia.org/wiki/Filename#Reserved_characters_and_words

Related Changesets

LimeSurvey: master 022af61e

2018-03-02 13:39:49

ollehar

Details Diff
Fixed issue 13396: Some files/folders not included in imported survey themes Affected Issues
13396
mod - application/controllers/admin/themes.php Diff File
mod - application/helpers/admin/template_helper.php Diff File

Issue History

Date Modified Username Field Change
2018-02-21 16:00 tpartner New Issue
2018-02-21 16:00 tpartner Status new => assigned
2018-02-21 16:00 tpartner Assigned To => LouisGac
2018-02-21 16:00 tpartner File Added: capture-6.png
2018-02-21 16:00 tpartner File Added: capture-5.png
2018-02-21 16:00 tpartner File Added: extends_bootswatch_mask_test.zip
2018-02-21 16:01 tpartner Description Updated View Revisions
2018-02-21 16:03 tpartner Description Updated View Revisions
2018-02-21 16:05 tpartner Description Updated View Revisions
2018-03-02 13:39 ollehar Assigned To LouisGac => ollehar
2018-03-02 13:40 ollehar Changeset attached => LimeSurvey master 022af61e
2018-03-02 13:40 ollehar Note Added: 46866
2018-03-02 13:40 ollehar Resolution open => fixed
2018-03-02 13:46 ollehar Note Added: 46867
2018-03-02 13:46 ollehar Status assigned => resolved
2018-03-02 13:46 ollehar Fixed in Version => 3.4.x
2018-03-02 14:01 tpartner Note Added: 46870
2018-03-05 17:31 ollehar Status resolved => closed