View Issue Details

IDProjectCategoryView StatusLast Update
13360Bug reports[All Projects] Survey takingpublic2018-02-19 15:09
ReportercookiemonsterAssigned Tomarkusfluer 
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version3.4.x 
Summary13360: Print answers does not work / gives an error
Description

Print answers gives an Internal Server Error
Property "Question.parent" is not defined.
An internal error occurred while the Web server was processing your request. Please contact the webmaster to report this problem.
Thank you.

Steps To Reproduce

finish a survey and click on "print answers"

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.3.0+180209
I will donate to the project if issue is resolvedNo
Browser58.0.2 (64-Bit)
Database & DB-Versionlibmysql - 5.5.54
Server OS (if known)Ubuntu
Webserver software & version (if known)Apache/2.4.7
PHP Version5.5.9

Activities

markusfluer

markusfluer

2018-02-15 12:57

administrator   ~46516

Can you add a survey .lss?
I couldn't reproduce it for now.

cookiemonster

cookiemonster

2018-02-15 13:54

reporter   ~46528

Seems it only affects specific surveys, basic ones without logic are not affected - I added a private lss, hope you can see it :D

markusfluer

markusfluer

2018-02-15 13:57

administrator   ~46529

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=26482

Related Changesets

LimeSurvey: master d0f2b71c

2018-02-15 13:57:18

markusfluer

Details Diff
Fixed issue 13360: Print answers does not work / gives an error Affected Issues
13360
mod - application/models/SurveyDynamic.php Diff File

Issue History

Date Modified Username Field Change
2018-02-15 10:26 cookiemonster New Issue
2018-02-15 12:57 markusfluer Note Added: 46516
2018-02-15 13:11 markusfluer Assigned To => markusfluer
2018-02-15 13:11 markusfluer Status new => feedback
2018-02-15 13:24 cookiemonster Status feedback => assigned
2018-02-15 13:54 cookiemonster Note Added: 46528
2018-02-15 13:57 markusfluer Changeset attached => LimeSurvey master d0f2b71c
2018-02-15 13:57 markusfluer Note Added: 46529
2018-02-15 13:57 markusfluer Resolution open => fixed
2018-02-15 13:57 markusfluer Status assigned => resolved
2018-02-15 13:57 markusfluer Fixed in Version => 3.3.x
2018-02-19 15:09 ollehar Status resolved => closed
2018-02-19 15:09 ollehar Fixed in Version 3.3.x => 3.4.x