View Issue Details

IDProjectCategoryView StatusLast Update
13355Bug reports[All Projects] Survey designpublic2018-02-19 15:09
ReporterolleharAssigned Tomarkusfluer 
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version3.3.x 
Target Version3.3.xFixed in Version3.4.x 
Summary13355: Saving German survey title shows JSON output
Description

Title.

Steps To Reproduce
  1. Import survey
  2. Click overview
  3. Click text elements
  4. Make sure there's a German title
  5. Click save
  6. JSON response in browser
TagsNo tags attached.
Complete LimeSurvey version number (& build)latest
I will donate to the project if issue is resolvedNo
Browser-
Database & DB-Version-
Server OS (if known)-
Webserver software & version (if known)-
PHP Version-

Activities

ollehar

ollehar

2018-02-14 17:34

administrator  

Selection_396.png (181,764 bytes)
c_schmitz

c_schmitz

2018-02-14 18:07

administrator   ~46484

Where is the survey?

ollehar

ollehar

2018-02-15 10:40

administrator   ~46501

Oops, forgot the survey.



limesurvey_survey_551929 (1).lss (17,542 bytes)
markusfluer

markusfluer

2018-02-15 12:50

administrator   ~46513

Can't reproduce.
Tested with path and get and pjax disabled.

ollehar

ollehar

2018-02-15 13:29

administrator   ~46521

Can you test with pjax enabled?

markusfluer

markusfluer

2018-02-15 13:48

administrator   ~46527

I did, same result.
Perfect form submission.

markusfluer

markusfluer

2018-02-15 14:16

administrator   ~46531

found the issue.
to reproduce.

  1. go to overview
  2. go to text elements
  3. go to any other pjax loaded page
  4. go to text elements
  5. click submit
markusfluer

markusfluer

2018-02-15 14:16

administrator   ~46532

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=26483

Related Changesets

LimeSurvey: master 798c95d5

2018-02-15 14:16:25

markusfluer

Details Diff
Fixed issue 13355: Saving German survey title shows JSON output Affected Issues
13355
mod - application/helpers/admin/htmleditor_helper.php Diff File

Issue History

Date Modified Username Field Change
2018-02-14 17:34 ollehar New Issue
2018-02-14 17:34 ollehar Status new => assigned
2018-02-14 17:34 ollehar Assigned To => markusfluer
2018-02-14 17:34 ollehar File Added: Selection_396.png
2018-02-14 18:07 c_schmitz Note Added: 46484
2018-02-15 10:40 ollehar File Added: limesurvey_survey_551929 (1).lss
2018-02-15 10:40 ollehar Note Added: 46501
2018-02-15 12:50 markusfluer Note Added: 46513
2018-02-15 12:50 markusfluer Status assigned => feedback
2018-02-15 13:28 ollehar Steps to Reproduce Updated View Revisions
2018-02-15 13:29 ollehar Note Added: 46521
2018-02-15 13:29 ollehar Status feedback => assigned
2018-02-15 13:48 markusfluer Note Added: 46527
2018-02-15 13:58 markusfluer Status assigned => feedback
2018-02-15 14:16 markusfluer Status feedback => acknowledged
2018-02-15 14:16 markusfluer Note Added: 46531
2018-02-15 14:16 markusfluer Status acknowledged => resolved
2018-02-15 14:16 markusfluer Resolution open => fixed
2018-02-15 14:16 markusfluer Fixed in Version => 3.3.x
2018-02-15 14:16 markusfluer Changeset attached => LimeSurvey master 798c95d5
2018-02-15 14:16 markusfluer Note Added: 46532
2018-02-19 15:09 ollehar Status resolved => closed
2018-02-19 15:09 ollehar Fixed in Version 3.3.x => 3.4.x