View Issue Details

IDProjectCategoryView StatusLast Update
13344Bug reports[All Projects] Survey designpublic2019-05-13 14:11
Reportersurv4711Assigned Todominikvitt 
PrioritynoneSeverityminor 
Status closedResolutionunable to reproduce 
Product Version3.3.x 
Target VersionFixed in Version 
Summary13344: $answertextright in do_array() is not properly initialized
Description

If there is a question using a pipe symbol as separator to get a left and right "question text" and a following question does not use a pipe symbol the variable keeps the former value.

Steps To Reproduce

Create a question array first question with pipe, second without, it will repeat the "right question" from the former.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.3.0 / 130042
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Versionmysql Ver 15.1
Server OS (if known)LInux
Webserver software & version (if known)Linux Apache 2.4
PHP Version7

Activities

ollehar

ollehar

2018-02-14 12:31

administrator   ~46440

Cannot reproduce. Please always attach a survey that reproduces the issue, and/or with a screenshot of it.

Issue History

Date Modified Username Field Change
2018-02-13 18:40 surv4711 New Issue
2018-02-14 12:31 ollehar Status new => feedback
2018-02-14 12:31 ollehar Note Added: 46440
2018-06-18 13:20 LouisGac Assigned To => dominikvitt
2018-06-18 13:20 LouisGac Status feedback => assigned
2019-05-13 14:11 dominikvitt Status assigned => resolved
2019-05-13 14:11 dominikvitt Resolution open => unable to reproduce
2019-05-13 14:11 dominikvitt Status resolved => closed