View Issue Details

This bug affects 1 person(s).
 2
IDProjectCategoryView StatusLast Update
13327Feature requestsResponse browsingpublic2018-03-30 05:35
Reporterroutard Assigned To 
PrioritynoneSeverityfeature 
Status newResolutionopen 
Summary13327: Error when manually editing an answer with a special character (simple quote)
DescriptionHi!
There is a bug when u want to manually edit an answer.
See the join file.
In my example, the answer is: Saint-Ouen-l'Aumone
This is the correct answer, which is visible in the answer list page.
As long as I don't manually edit an aswer with a text field containing a special character, it's OK.
But when I edit an answer containing a simple quote, the text field is cut after the simple quote.
I think it's because the special character is not escaped in the sql query, function like mysqli_real_escape_string.
I think it's the same thing with others spacial characters, didn't tried (only with simple quote)

For now, impossible to edit the answers, (or I have the access the database thru phpmyadmi but it's far toooooooo long).

Thx for fixing it!
TagsNo tags attached.
Bug heat2

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

routard

routard

2018-02-09 18:32

reporter  

LS.jpg (255,344 bytes)
routard

routard

2018-03-30 05:35

reporter   ~47290

up?

Issue History

Date Modified Username Field Change
2018-02-09 18:32 routard New Issue
2018-02-09 18:32 routard File Added: LS.jpg
2018-03-30 05:35 routard Note Added: 47290