View Issue Details

IDProjectCategoryView StatusLast Update
13245Bug reports[All Projects] _ Unknownpublic2018-02-22 14:18
Reporterfajardas Assigned Tomarkusfluer  
PrioritynoneSeverityfeature 
Status closedResolutionfixed 
Product Version3.1.x 
Target VersionFixed in Version3.1.x 
Summary13245: Error Message when a survey "Use CAPTCHA for survey access" is ON
Description

When i choose the option "Use CAPTCHA for survey access" - ON, and execute survey, display an error message.
"Internal Server Error - Calling '__tostring" method on a LSCaptcha" object is not allowed in...'"

Steps To Reproduce

On a survey goto: Publication & access - > Use CAPTCHA for survey access: ON

TagsNo tags attached.
Complete LimeSurvey version number (& build)LS Version 3.1.0+180124
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionMySQL - 5.7.20
Server OS (if known)Ubuntu
Webserver software & version (if known)Apache/2.4.27
PHP Version7.1.12-3

Activities

fajardas

fajardas

2018-01-25 11:43

reporter  

Capture2.PNG (27,612 bytes)
Capture2.PNG (27,612 bytes)
Capture.PNG (19,981 bytes)
Capture.PNG (19,981 bytes)
fajardas

fajardas

2018-01-25 12:02

reporter   ~46080

This error appears in a custom template, it did not happen in version 3.0.5

LouisGac

LouisGac

2018-01-25 12:09

manager   ~46081

template has been changed a bit to solve a bug on captcha, please, if you change some twig files, compare what changed in beetween.
(this should not happen too often )

c_schmitz

c_schmitz

2018-01-25 12:34

administrator   ~46082

Does it happen with a standard template?

fajardas

fajardas

2018-01-25 14:28

reporter   ~46087

With a standard template, the captcha appears, but i dont see the button "Continue"...

Thank you.

LouisGac

LouisGac

2018-01-26 13:16

manager   ~46108

I can't reproduce, maybe it's already fixed

markusfluer

markusfluer

2018-01-26 14:36

administrator   ~46112

This should be fixed in current master. See commit 52ad8554b2373403efe2d5d3c176a588c7f5c9d5

markusfluer

markusfluer

2018-01-31 12:40

administrator   ~46174

Fixed in Commit #306712a17755a3ed7f5d8cbe88de23398d774060

c_schmitz

c_schmitz

2018-02-09 17:02

administrator   ~46355

Version 3.3.0 released

Issue History

Date Modified Username Field Change
2018-01-25 11:43 fajardas New Issue
2018-01-25 11:43 fajardas File Added: Capture2.PNG
2018-01-25 11:43 fajardas File Added: Capture.PNG
2018-01-25 12:02 fajardas Note Added: 46080
2018-01-25 12:09 LouisGac Note Added: 46081
2018-01-25 12:34 c_schmitz Assigned To => c_schmitz
2018-01-25 12:34 c_schmitz Status new => feedback
2018-01-25 12:34 c_schmitz Note Added: 46082
2018-01-25 14:28 fajardas Note Added: 46087
2018-01-25 14:28 fajardas Status feedback => assigned
2018-01-25 14:33 c_schmitz Assigned To c_schmitz => markusfluer
2018-01-26 12:46 LouisGac Sticky Issue No => Yes
2018-01-26 13:16 LouisGac Note Added: 46108
2018-01-26 14:36 markusfluer Note Added: 46112
2018-01-31 12:40 markusfluer Status assigned => resolved
2018-01-31 12:40 markusfluer Resolution open => fixed
2018-01-31 12:40 markusfluer Fixed in Version => 3.1.x
2018-01-31 12:40 markusfluer Note Added: 46174
2018-02-09 17:02 c_schmitz Note Added: 46355
2018-02-09 17:02 c_schmitz Status resolved => closed
2018-02-22 14:18 c_schmitz Sticky Issue Yes => No