View Issue Details

IDProjectCategoryView StatusLast Update
13237Bug reports[All Projects] Import/Exportpublic2018-01-25 12:33
Reporterrob040Assigned Toc_schmitz 
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.0.x 
Target VersionFixed in Version3.1.x 
Summary13237: Problem with opening Excel export
Description

When opening an export of the responses in Excel 2016 the following error message pops up:

"Excel cannot open the file 'filename.xlsx' because the file format for the file extension is not valid. Verify that the file has not been corrupted and that the file extension matches the format of the file."

Editing the file in Notepad++ shows white lines at the start of the file and missing closing tags at the end of the file. Removing the white line at the start of the file results in Excel trying to repair the file (which eventually works).

Steps To Reproduce

In a survey go to Responses > Responses & Statistics > Export > Export responses. Select Microsoft Excel and click on Export. Open the file in Excel. Then the error message pops up.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.0.5+180118
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionMySQL 5.5.59
Server OS (if known)‪CentOS 6.9
Webserver software & version (if known)Apache/2.2.15
PHP Version5.6.33

Activities

c_schmitz

c_schmitz

2018-01-24 16:27

administrator   ~46025

I have no problems with this in 3.1.0 - can you please update, test and if you still have this problem add an example erroneous file ?

rob040

rob040

2018-01-25 11:05

reporter   ~46079

The problem is solved in 3.1.0. Thank you.

Issue History

Date Modified Username Field Change
2018-01-24 10:37 rob040 New Issue
2018-01-24 16:27 c_schmitz Assigned To => c_schmitz
2018-01-24 16:27 c_schmitz Status new => feedback
2018-01-24 16:27 c_schmitz Note Added: 46025
2018-01-25 11:05 rob040 Note Added: 46079
2018-01-25 11:05 rob040 Status feedback => assigned
2018-01-25 12:33 c_schmitz Status assigned => closed
2018-01-25 12:33 c_schmitz Resolution open => fixed
2018-01-25 12:33 c_schmitz Fixed in Version => 3.1.x