View Issue Details

IDProjectCategoryView StatusLast Update
13141Bug reports[All Projects] Survey participants (Tokens)public2018-02-07 17:06
ReportercookiemonsterAssigned Toolle 
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version3.2.x 
Summary13141: Filters or rows per page won't work on default page
DescriptionFilters or rows per page won't work on default page (nothing happens)
-> index.php/admin/tokens/sa/browse/surveyid/1234

After sorting via any column it is working
-> index.php/admin/tokens?

So scripts of first link are broken, second one works fine.
Steps To ReproduceJust open participants default view
Additional InformationWorkaround: sort first, then it works
TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.0.1+171228
I will donate to the project if issue is resolvedNo
BrowserFirefox 57.0.4 (64-Bit)
Database & DB-Versionlibmysql - 5.5.54
Operating System (Server)Ubuntu
Webserver software & versionApache/2.4.7
PHP Version5.5.9

Activities

snowsam

snowsam

2018-01-08 19:36

reporter   ~45496

+1
I see the same issue with "rows per page" not working on my install.
cookiemonster

cookiemonster

2018-01-09 08:26

reporter   ~45499

additional note: doesn't work on other pages as well (e.g. Answers page - survey/index.php/admin/responses/sa/browse/surveyid/123456 - same behavior)
olle

olle

2018-02-02 16:11

administrator   ~46218

This was fixed, right?
cookiemonster

cookiemonster

2018-02-05 08:33

reporter   ~46246

Yep, works in newest version, but: rows per page dropdown seems to be bugged, doesn't change the value, always stays at 10, whatever you choose.
Therefore you can't change back to 10 and as soon as the list reloads, it seems to reload 4 times instead of 1 time.
olle

olle

2018-02-06 15:10

administrator   ~46285

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=26363

Related Changesets

LimeSurvey: master ec558ccf

2018-02-06 15:10:11

olle

Details Diff
Fixed issue 13141: Filters or rows per page won't work on default page
mod - application/extensions/admin/grid/MassiveActionsWidget/assets/listActions.js Diff File
mod - application/views/admin/token/browse.php Diff File
mod - assets/scripts/admin/tokens.js Diff File

Issue History

Date Modified Username Field Change
2018-01-08 16:35 cookiemonster New Issue
2018-01-08 19:36 snowsam Note Added: 45496
2018-01-09 08:26 cookiemonster Note Added: 45499
2018-01-15 10:52 LouisGac Assigned To => olle
2018-01-15 10:52 LouisGac Status new => assigned
2018-02-02 16:11 olle Status assigned => feedback
2018-02-02 16:11 olle Note Added: 46218
2018-02-05 08:33 cookiemonster Note Added: 46246
2018-02-05 08:33 cookiemonster Status feedback => assigned
2018-02-06 15:10 olle Changeset attached => LimeSurvey master ec558ccf
2018-02-06 15:10 olle Note Added: 46285
2018-02-06 15:10 olle Resolution open => fixed
2018-02-06 15:14 olle Status assigned => resolved
2018-02-06 15:14 olle Fixed in Version => 3.2.x
2018-02-07 17:06 olle Status resolved => closed