View Issue Details

IDProjectCategoryView StatusLast Update
13129Bug reports[All Projects] Survey designpublic2018-01-30 14:08
Reporterabc99Assigned Tomarkusfluer 
PrioritynoneSeveritymajor 
Status closedResolutionunable to reproduce 
Product Version3.0.0-rc.x 
Target VersionFixed in Version 
Summary13129: can't upload images: "You don't have permissions to browse server."
DescriptionWhen trying to upload images I get "You don't have permissions to browse server."

Steps To Reproducenavigate to resources sub menu item (/admin/survey/sa/rendersidemenulink/subaction/resources/surveyid/174927)

or:

try to insert an image in the question editor, click browse (see screenshot)
TagsNo tags attached.
Complete LimeSurvey version number (& build)3.0.0.rc3
I will donate to the project if issue is resolvedNo
Browserchrome, firefox, edge
Database & DB-Versionirrelevant
Operating System (Server)linux
Webserver software & versionapache
PHP Version7.1

Activities

abc99

abc99

2018-01-06 04:40

reporter  

Capture.PNG (20,532 bytes)
Capture.PNG (20,532 bytes)
GNI

GNI

2018-01-18 16:46

reporter   ~45897

I use version 3.0.4 and I still have this issue.

try to insert an image in the question editor, click browse (see screenshot)
or
/admin/survey/sa/rendersidemenulink/subaction/resources/surveyid/xxxxxx
GNI

GNI

2018-01-30 14:08

reporter   ~46148

I found the issue.

Upload directory need to be owned by user apache (chown -R apache <directory>).
If user apache have read/write access to the directory with group membership it is not enough.

Issue History

Date Modified Username Field Change
2018-01-06 04:40 abc99 New Issue
2018-01-06 04:40 abc99 File Added: Capture.PNG
2018-01-08 11:33 LouisGac Assigned To => markusfluer
2018-01-08 11:33 LouisGac Status new => assigned
2018-01-15 10:54 LouisGac Status assigned => closed
2018-01-15 10:54 LouisGac Resolution open => unable to reproduce
2018-01-18 16:46 GNI Note Added: 45897
2018-01-30 14:08 GNI Note Added: 46148