View Issue Details

IDProjectCategoryView StatusLast Update
12994Bug reports[All Projects] Theme editorpublic2018-05-23 11:24
ReportersimogeoAssigned ToLouisGac 
PrioritynoneSeveritycrash 
Status closedResolutionunable to reproduce 
Product Version2.7x.x 
Target VersionFixed in Version 
Summary12994: Error when editing duplicated templates
Description

I'm using Version 2.72.5+171121

I just duplicated Default templates (from fresh install) and edit the new one from Online editor.

When saving, I get an error page displaying :

<code>
Erreur interne du serveur
Call to undefined method stdClass::asXML()

Une erreur interne est apparue lorsque le serveur web traitait votre requete. Veuillez contacter the webmaster pour signaler ce problème.
</code>

By the way, changes are save.

when setting debug level to '2'. I get more info. See screenshot below

TagsNo tags attached.
Complete LimeSurvey version number (& build)2.72.5+171121
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Versionmysqlnd 5.0.12-dev - 20150407
Operating System (Server)linux Debian 4.9.51-1
Webserver software & versionnginx
PHP VersionPHP Version 7.0.19-1

Activities

simogeo

simogeo

2017-12-06 15:08

reporter  

LM-bug.png (123,673 bytes)
simogeo

simogeo

2017-12-06 15:10

reporter   ~45249

Error happens on the following page http://www.survey.xxxx/index.php?r=admin/templates/sa/templatesavechanges

LouisGac

LouisGac

2018-05-23 11:24

manager   ~47739

LS3 Theme Editor is using a different engine

Issue History

Date Modified Username Field Change
2017-12-06 15:08 simogeo New Issue
2017-12-06 15:08 simogeo File Added: LM-bug.png
2017-12-06 15:10 simogeo Note Added: 45249
2018-05-23 11:24 LouisGac Assigned To => LouisGac
2018-05-23 11:24 LouisGac Status new => closed
2018-05-23 11:24 LouisGac Resolution open => unable to reproduce
2018-05-23 11:24 LouisGac Note Added: 47739