View Issue Details

IDProjectCategoryView StatusLast Update
12938Development Survey Designpublic2017-12-07 09:12
ReportertpartnerAssigned Tomarkusfluer 
PrioritynoneSeveritymajor 
Status resolvedResolutionfixed 
Product Version3.x 
Target VersionFixed in Version3.x 
Summary12938: No "Close" or "Save and close" buttons when editing
DescriptionThe only button available when editing survey properties, answers or sub-questions is "Save". This gives the user no options.
TagsNo tags attached.

Relationships

duplicate of 12897 resolvedmarkusfluer Bug reports No more "Save & close" button for saving a question 

Activities

tpartner

tpartner

2017-11-21 13:38

developer  

capture-2.png (21,362 bytes)
capture-2.png (21,362 bytes)
markusfluer

markusfluer

2017-11-29 14:35

developer   ~45194

Last edited: 2017-11-29 14:42

View 2 revisions

the "Save and Close" got applied again for all settings with a minimal deepness of 2. Meaning question editing, subquestion editing and answer editing.
A close button isn't necessary. Just close the page, or open anotherone, or hit the backbutton to leave.

tpartner

tpartner

2017-11-29 14:56

developer   ~45196

I disagree. I don't think it's good practice to ask a user to use their back button or other navigation to exit a page without making changes. I think it needs a "close" or "cancel" button that returns them to the question overview.
markusfluer

markusfluer

2017-12-07 09:11

developer   ~45250

In my opinion, the close button is not necessary. But since my opinion is only one of many, and many said they want it back, it's back now.
markusfluer

markusfluer

2017-12-07 09:12

developer   ~45251

Fix committed to develop branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=25376

Related Changesets

LimeSurvey: develop 3d70c4e7

2017-12-07 09:11:16

markusfluer

Details Diff
Fixed issue 12938: No "Close" or "Save and close" buttons when editing
mod - application/views/admin/survey/Question/questionbar_view.php Diff File
mod - application/views/admin/survey/QuestionGroups/questiongroupbar_view.php Diff File

Issue History

Date Modified Username Field Change
2017-11-21 13:38 tpartner New Issue
2017-11-21 13:38 tpartner File Added: capture-2.png
2017-11-29 14:35 markusfluer Note Added: 45194
2017-11-29 14:42 markusfluer Note Edited: 45194 View Revisions
2017-11-29 14:42 markusfluer Assigned To => markusfluer
2017-11-29 14:42 markusfluer Status new => resolved
2017-11-29 14:42 markusfluer Resolution open => fixed
2017-11-29 14:42 markusfluer Fixed in Version => 3.x
2017-11-29 14:56 tpartner Status resolved => feedback
2017-11-29 14:56 tpartner Resolution fixed => reopened
2017-11-29 14:56 tpartner Note Added: 45196
2017-12-07 09:08 markusfluer Relationship added related to 12897
2017-12-07 09:08 markusfluer Relationship deleted related to 12897
2017-12-07 09:08 markusfluer Relationship added duplicate of 12897
2017-12-07 09:11 markusfluer Status feedback => resolved
2017-12-07 09:11 markusfluer Resolution reopened => duplicate
2017-12-07 09:11 markusfluer Note Added: 45250
2017-12-07 09:12 markusfluer Changeset attached => LimeSurvey develop 3d70c4e7
2017-12-07 09:12 markusfluer Note Added: 45251
2017-12-07 09:12 markusfluer Resolution duplicate => fixed