View Issue Details

IDProjectCategoryView StatusLast Update
12898Bug reports[All Projects] Survey designpublic2018-06-11 16:29
ReporterEinkauf.ZITAssigned Todominikvitt 
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version2.7x.x 
Target VersionFixed in Version3.10.x 
Summary12898: Repeat Headers not working in array dual scale with dropdown layout
Description

Hello,

I set the value for "Repeat Headers" in Question B2 to 10, but the column headers will not be repeated.

Please check, thank you! :)

Kind regards,

Klaus

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 2.72.3+171020
I will donate to the project if issue is resolvedNo
Browsereach Browser
Database & DB-VersionmySQL 5.7
Operating System (Server)Windows 2012 R2 Server
Webserver software & versionIIS 8.5
PHP VersionPHP Version 7.1.1

Activities

Einkauf.ZIT

Einkauf.ZIT

2017-11-13 12:42

reporter  

limesurvey_survey_776867.lss (206,534 bytes)
Einkauf.ZIT

Einkauf.ZIT

2017-11-16 09:51

reporter   ~45090

Hello,

any news?

Kind regards,

Klaus Kral

Einkauf.ZIT

Einkauf.ZIT

2017-11-20 12:25

reporter   ~45111

Hello?
Anybody out there?

Einkauf.ZIT

Einkauf.ZIT

2017-11-27 10:06

reporter   ~45158

So, no reaction?

DenisChenu

DenisChenu

2017-11-28 11:33

developer   ~45176

repeat headers don't work with use_dropdown , think it was since a lot of time …

Einkauf.ZIT

Einkauf.ZIT

2017-11-28 13:26

reporter   ~45177

Hello,

aha, ok, interesting.

But where is the problem, that headers cannot repeat with dropdowns?

Ticket can be closed, but maybe you think about a solution for using repeat headers with dropdowns too.

Thank you!

Kind regards,

Klaus

LouisGac

LouisGac

2018-06-04 14:40

manager   ~47964

dominik: could you please rename "repeat headers" to "repeat answer options"?
thanks

guest

guest

2018-06-06 15:57

viewer   ~48008

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=27345

dominikvitt

dominikvitt

2018-06-06 16:03

developer   ~48009

Caption is changed to prevent future misunderstanding, because this option should work only for answer options.

Related Changesets

LimeSurvey: master 3119c975

2018-06-06 15:57:13

Dominik Vitt

Details Diff
Fixed issue 12898: Repeat Headers not working in array dual scale with dropdown layout

Changed the caption for Repeat headers option
mod - application/helpers/questionHelper.php Diff File

Issue History

Date Modified Username Field Change
2017-11-13 12:42 Einkauf.ZIT New Issue
2017-11-13 12:42 Einkauf.ZIT File Added: limesurvey_survey_776867.lss
2017-11-16 09:51 Einkauf.ZIT Note Added: 45090
2017-11-20 12:25 Einkauf.ZIT Note Added: 45111
2017-11-27 10:06 Einkauf.ZIT Note Added: 45158
2017-11-28 11:33 DenisChenu Note Added: 45176
2017-11-28 11:33 DenisChenu Status new => confirmed
2017-11-28 11:33 DenisChenu Summary Repeat Headers not working => Repeat Headers not working in array dual scale with dropdown layout
2017-11-28 13:26 Einkauf.ZIT Note Added: 45177
2018-05-23 11:27 LouisGac Assigned To => dominikvitt
2018-05-23 11:27 LouisGac Status confirmed => assigned
2018-06-04 14:40 LouisGac Note Added: 47964
2018-06-06 15:57 Changeset attached => LimeSurvey master 3119c975
2018-06-06 15:57 guest Note Added: 48008
2018-06-06 15:57 guest Resolution open => fixed
2018-06-06 16:03 dominikvitt Status assigned => resolved
2018-06-06 16:03 dominikvitt Fixed in Version => 3.8.x
2018-06-06 16:03 dominikvitt Note Added: 48009
2018-06-11 16:29 markusfluer Status resolved => closed
2018-06-11 16:29 markusfluer Fixed in Version 3.8.x => 3.10.x