View Issue Details

IDProjectCategoryView StatusLast Update
12868Bug reports[All Projects] ComfortUpdatepublic2018-05-30 18:02
ReporterPetteri66 Assigned ToLouisGac  
PrioritynoneSeveritymajor 
Status closedResolutionreopened 
Product Version3.0.0-rc.x 
Target VersionFixed in Version3.8.x 
Summary12868: Updating to 3.0xx
Description

After upgrading 2.7. version through comfortUpdate to 3.0-rc an error message appears when wanting to create a survey.

Steps To Reproduce

I just upgraded my 2.7. version (in my "test enviroment") through comfortUpdate to 3.0-rc . The installation went ok, no error messages. The administration overview is ok and I can enter global function, template editor, but when I want to open my surveys or create a new one, I get an internal failure message (see attached). Any ideas what this could be?

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.0.0-beta.3+171025
I will donate to the project if issue is resolvedNo
Browserchrome
Database & DB-Versionmysql
Server OS (if known)-
Webserver software & version (if known)-
PHP Version-

Relationships

duplicate of 12855 closedollehar Primary key on group.gid diable multilingual survey 

Activities

Petteri66

Petteri66

2017-11-04 09:21

reporter  

limesurvey-300.JPG (27,886 bytes)
limesurvey-300.JPG (27,886 bytes)
LouisGac

LouisGac

2017-11-06 10:31

manager   ~44979

Thank you for testing the RC !

Yes this bug is known:
https://bugs.limesurvey.org/view.php?id=12855

DenisChenu

DenisChenu

2017-11-06 11:14

developer   ~44980

@LouisGac : no, completely different

This one : when update Survey.gsid is not created
The other : when install (new DB) SurveyGroup.gid is set as unique key

:)

LouisGac

LouisGac

2017-11-06 11:15

manager   ~44981

ok thank you

hansos

hansos

2017-11-07 14:02

reporter   ~44987

Same issue here but using MS SQL

DenisChenu

DenisChenu

2017-11-07 15:49

developer   ~44988

Last edited: 2017-11-07 15:50

View 2 revisions

OK, seems fixed with last version (GIT f73efcd24)

Petteri66

Petteri66

2017-11-07 16:10

reporter   ~44989

Yes, everything works fine now. Thank you!

DenisChenu

DenisChenu

2017-12-20 22:08

developer   ~45352

Same issue just now.

What i done :

  1. Copy a LimeSurvey 2.73.0.0 DB
  2. Clone 2.73 just now
  3. Setup new install
  4. Unlog
  5. Checkout develop
  6. Login
  7. Accept DB update
  8. COme back to login after update
  9. See La propriété « Survey.gsid » est indéfinie.
    9 : set debug at 2
    10 : reload : error is gone

Maybe related to a DB cache issue ?

Issue History

Date Modified Username Field Change
2017-11-04 09:21 Petteri66 New Issue
2017-11-04 09:21 Petteri66 Status new => assigned
2017-11-04 09:21 Petteri66 Assigned To => LouisGac
2017-11-04 09:21 Petteri66 File Added: limesurvey-300.JPG
2017-11-06 10:31 LouisGac Note Added: 44979
2017-11-06 10:31 LouisGac Relationship added duplicate of 12855
2017-11-06 11:14 DenisChenu Note Added: 44980
2017-11-06 11:15 LouisGac Note Added: 44981
2017-11-07 14:02 hansos Note Added: 44987
2017-11-07 15:49 DenisChenu Note Added: 44988
2017-11-07 15:50 DenisChenu Note Edited: 44988 View Revisions
2017-11-07 16:10 Petteri66 Note Added: 44989
2017-11-07 16:51 LouisGac Status assigned => resolved
2017-11-07 16:51 LouisGac Resolution open => duplicate
2017-12-20 22:08 DenisChenu Status resolved => feedback
2017-12-20 22:08 DenisChenu Resolution duplicate => reopened
2017-12-20 22:08 DenisChenu Note Added: 45352
2018-05-30 18:02 LouisGac Status feedback => closed
2018-05-30 18:02 LouisGac Fixed in Version => 3.8.x